aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-11-04 10:26:17 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-11-04 10:29:36 +0100
commita019e11ed2e425131cba601db74b569cab5bab3d (patch)
treed168c780f59baf6cadb7eaada4ca428e3afa9b3d
parent69ac9b72ce3914c2d1c07f80a2e1db85c9035e5d (diff)
downloadguix-a019e11ed2e425131cba601db74b569cab5bab3d.tar.gz
guix-a019e11ed2e425131cba601db74b569cab5bab3d.zip
gnu: Add python-hotspotsc.
* gnu/packages/bioinformatics.scm (python-hotspotsc): New variable. Change-Id: Ib3550837659f95d5a43e77137005db8cc03e6c3f
-rw-r--r--gnu/packages/bioinformatics.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ea38a10277..10ecac18ae 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2421,6 +2421,58 @@ from single-cell RNA-sequencing.")
to produce high quality figures that can be used in publications.")
(license license:expat)))
+(define-public python-hotspotsc
+ (package
+ (name "python-hotspotsc")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "hotspotsc" version))
+ (sha256
+ (base32 "1phbd49nb0ivfcgfi6yxd2masgd0v6133mki9vd5pkrhx0a7wb5d"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:tests? #false ;there are none
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'use-poetry-core
+ (lambda _
+ ;; Patch to use the core poetry API.
+ (substitute* "pyproject.toml"
+ (("poetry.masonry.api")
+ "poetry.core.masonry.api")
+ ;; Fix syntax error
+ (("sphinx>") "sphinx")))))))
+ (propagated-inputs (list python-anndata
+ python-importlib-metadata
+ python-ipython
+ python-matplotlib
+ python-nbsphinx
+ python-numba
+ python-numpy
+ python-pandas
+ python-pynndescent
+ python-scanpy
+ python-scikit-learn
+ python-scipy
+ python-seaborn
+ python-statsmodels
+ python-tqdm))
+ (native-inputs
+ (list python-poetry-core python-pytest python-sphinx))
+ (home-page "https://github.com/yoseflab/hotspot")
+ (synopsis
+ "Identifying informative genes in a single-cell dataset")
+ (description
+ "Hotspot is a tool for identifying informative genes (and gene modules)
+in a single-cell dataset. Importantly, \"informative\" is decided based on
+how well a gene's variation agrees with some cell metric---some similarity
+mapping between cells. Genes which are informative are those whose expression
+varies in similar way among cells which are nearby in the given metric.")
+ (license license:expat)))
+
(define-public python-htsget
(package
(name "python-htsget")