aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:52:06 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:37 +0200
commit9ed78d0e2e361fca07338c63cf95a4ec3f2d57e0 (patch)
tree7ec20f856e1353634c14d3ce37d183b1da02d1e4
parent831a550c22226a8eae00c31c1ab463b117bd0558 (diff)
downloadguix-9ed78d0e2e361fca07338c63cf95a4ec3f2d57e0.tar.gz
guix-9ed78d0e2e361fca07338c63cf95a4ec3f2d57e0.zip
gnu: Add texlive-plex.
* gnu/packages/tex.scm (texlive-plex): New variable.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d25e6b3338..7f28fba181 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -21250,6 +21250,33 @@ characters. This helps achieve a more even typographical colour when
typesetting proper nouns and initialisms.")
(license (list license:silofl1.1 license:lppl))))
+(define-public texlive-plex
+ (package
+ (name "texlive-plex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/plex/"
+ "fonts/enc/dvips/plex/"
+ "fonts/map/dvips/plex/"
+ "fonts/opentype/ibm/plex/"
+ "fonts/tfm/ibm/plex/"
+ "fonts/type1/ibm/plex/"
+ "fonts/vf/ibm/plex/"
+ "tex/latex/plex/")
+ (base32
+ "0lvv5p2jmkr7cb0rml4iyzr5pf7bfks0a44sv49v1d2492j57jmv")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/plex")
+ (synopsis "Support for IBM Plex fonts")
+ (description
+ "The package provides LaTeX, pdfLaTeX, XeLaTeX and LuaLaTeX support for
+the IBM Plex families of fonts. Serif, Sans and Mono families are available
+in eight weights: Regular, Light, ExtraLight, Thin, Bold, Text, Medium and
+SemiBold (with corresponding italics).")
+ (license (list license:silofl1.1 license:lppl))))
+
(define-public texlive-pm-isomath
(package
(name "texlive-pm-isomath")