aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-18 13:00:33 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:06 +0200
commit9ea5b4681cb33b175235252a48a3a57ce35cbfe8 (patch)
treee4c63d603140249a34c796507a6908e91c914877
parent7b45ead9ec40a5ea1ef8332d55c2bb4beff85eb5 (diff)
downloadguix-9ea5b4681cb33b175235252a48a3a57ce35cbfe8.tar.gz
guix-9ea5b4681cb33b175235252a48a3a57ce35cbfe8.zip
gnu: Add texlive-amiri.
* gnu/packages/tex.scm (texlive-amiri): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 80d1d33be2..e32d5cd42d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1826,6 +1826,29 @@ Taco Hoekwater.")
processing the output of Metafont.")
(license license:public-domain)))
+(define-public texlive-amiri
+ (package
+ (name "texlive-amiri")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/amiri/"
+ "fonts/truetype/public/amiri/")
+ (base32
+ "1d6yrh34fka9371a3vq72df593prik6s7z1i6myd0nix0c9jihp6")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/amiri")
+ (synopsis "Classical Arabic typeface, Naskh style")
+ (description
+ "Amiri is a classical Arabic typeface in Naskh style for typesetting books
+and other running text. It is a revival of the beautiful typeface pioneered
+in the early 20th century by Bulaq Press in Cairo, also known as Amiria Press,
+after which the font is named. The project aims at the revival of the
+aesthetics and traditions of Arabic typesetting, and adapting it to the era of
+digital typesetting, in a publicly available form.")
+ (license license:silofl1.1)))
+
(define-public texlive-amsfonts
(package
(name "texlive-amsfonts")