aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 01:00:59 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:02 +0800
commit9e77164e0adfcd67777e15b0273a6edbcf88949b (patch)
tree99e8d7e454e21a11400493d6f9cf5f2ee9e2c9f7
parent96912c3a71a3d41ea55a1f798a0b3d130c607c52 (diff)
downloadguix-9e77164e0adfcd67777e15b0273a6edbcf88949b.tar.gz
guix-9e77164e0adfcd67777e15b0273a6edbcf88949b.zip
gnu: Add kcolorscheme.
* gnu/packages/kde-frameworks.scm (kcolorscheme): New variable. Change-Id: I5c2b94eb6b6d5e0a0d1faf313f2bf1bc8b4da2ce
-rw-r--r--gnu/packages/kde-frameworks.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 17f5f0d169..4ddf3ab859 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -590,6 +590,36 @@ menu which lets you select a color. The popup features a color dialog button
which can be used to add custom colors to the popup menu.")
(license license:lgpl3+)))
+(define-public kcolorscheme
+ (package
+ (name "kcolorscheme")
+ (version "6.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+
+ (sha256
+ (base32
+ "0dch0iv6kkbzc7cl5fbcls1ll2h4jdd16kv9g5d9y041ryyk05ri"))))
+ (build-system qt-build-system)
+ (native-inputs (list extra-cmake-modules))
+ (inputs (list kguiaddons ki18n
+ qtdeclarative))
+ (propagated-inputs (list kconfig))
+ (arguments (list #:qtbase qtbase))
+ (synopsis "Classes to read and interact with KColorScheme")
+ (description "This package provide a Classes to read and interact with
+KColorScheme.")
+ (home-page "https://community.kde.org/Frameworks")
+ (license (list license:cc0
+ license:lgpl2.0+
+ license:lgpl2.1
+ license:bsd-2
+ license:lgpl3))))
+
(define-public kconfig
(package
(name "kconfig")