aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:54:20 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:57 +0000
commit9e2fe5431e4d70020378cdd13f1f094808f03ea9 (patch)
tree9e531064e494f7ab73c83842bd715e526ae74bd5
parentd8cf06e6bbb449f8c889655698032738aeebbdc9 (diff)
downloadguix-9e2fe5431e4d70020378cdd13f1f094808f03ea9.tar.gz
guix-9e2fe5431e4d70020378cdd13f1f094808f03ea9.zip
gnu: python-warcio: Move to pyproject-build-system.
* gnu/packages/python-web.scm (python-warcio): [build-system]: Move to pyproject-build-system. [arguments]: Use <#:test-flags> instead of check phase replacement. Change-Id: I7fd1ad51cddcbeb42c6aeeda552eb1a7bcd6e712 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-web.scm26
1 files changed, 10 insertions, 16 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 66bcddea81..e8d85177bb 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7019,24 +7019,18 @@ them to a designated prefix.")
(sha256
(base32
"11afr6zy3r6rda81010iq496dazg4xid0izg3smg6ighpmvsnzf2"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
(list
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv"
- ;; These tests fail due to networking requirements.
- "-k" (format #f "not ~a"
- (string-join
- '("test_post_chunked"
- "test_remote"
- "test_capture_http_proxy"
- "test_capture_https_proxy"
- "test_capture_https_proxy_same_session")
- " and not ")))))))))
+ #:test-flags ; These tests fail due to networking requirements.
+ '(list "-k" (format #f "not ~a"
+ (string-join
+ '("test_post_chunked"
+ "test_remote"
+ "test_capture_http_proxy"
+ "test_capture_https_proxy"
+ "test_capture_https_proxy_same_session")
+ " and not ")))))
(native-inputs
;; These inputs are required for the test suite.
(list python-httpbin python-pytest-cov python-requests