aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-07-26 19:20:53 +0200
committerLudovic Courtès <ludo@gnu.org>2024-07-26 19:21:33 +0200
commit9db34c41acae675041e2d0a72e72688b7b58d114 (patch)
tree3b85624bbeff75bc01bb5fef5a919de1c7af0913
parent4bc49e2185179fbbc96a06ff0a921021f746011a (diff)
downloadguix-9db34c41acae675041e2d0a72e72688b7b58d114.tar.gz
guix-9db34c41acae675041e2d0a72e72688b7b58d114.zip
build-system/meson: #:test-options can be a gexp.
* guix/build-system/meson.scm (meson-build, meson-cross-build): Accept gexps for #:test-options. Change-Id: I9cfec616f067a5c9928f65892e370f90f23f4352
-rw-r--r--guix/build-system/meson.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/guix/build-system/meson.scm b/guix/build-system/meson.scm
index 04d2241c79..13baf329df 100644
--- a/guix/build-system/meson.scm
+++ b/guix/build-system/meson.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017 Peter Mikkelsen <petermikkelsen10@gmail.com>
;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2021, 2022 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2021-2022, 2024 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
;;;
@@ -239,7 +239,9 @@ has a 'meson.build' file."
configure-flags)
#:build-type #$build-type
#:tests? #$tests?
- #:test-options #$(sexp->gexp test-options)
+ #:test-options #$(if (pair? test-options)
+ (sexp->gexp test-options)
+ test-options)
#:parallel-build? #$parallel-build?
#:parallel-tests? #$parallel-tests?
#:validate-runpath? #$validate-runpath?
@@ -352,7 +354,9 @@ SOURCE has a 'meson.build' file."
configure-flags))
#:build-type #$build-type
#:tests? #$tests?
- #:test-options #$(sexp->gexp test-options)
+ #:test-options #$(if (pair? test-options)
+ (sexp->gexp test-options)
+ test-options)
#:parallel-build? #$parallel-build?
#:parallel-tests? #$parallel-tests?
#:validate-runpath? #$validate-runpath?