aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin <benjamin@uvy.fr>2024-03-24 00:35:14 +0100
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-23 11:47:48 +0100
commit9dade47155723c5a4b70af27f3dadb336c31f95d (patch)
treecff8eb31dbb5ae0d62ba6d2e7e553d117b69da66
parent2b872b27df3b7169cc959434646442b5fdc90a34 (diff)
downloadguix-9dade47155723c5a4b70af27f3dadb336c31f95d.tar.gz
guix-9dade47155723c5a4b70af27f3dadb336c31f95d.zip
gnu: Add ocaml-xdg.
* gnu/packages/ocaml.scm (ocaml-xdg): New variable. Change-Id: I88bc2fd7bb55d721ce1887a727480338dea0590c Signed-off-by: Danny Milosavljevic <dannym@friendly-machines.com>
-rw-r--r--gnu/packages/ocaml.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 899bf4a155..403dc478dc 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8732,6 +8732,21 @@ or the list of statically linked libraries with their versions. It supports
reporting the version from the version control system during development to
get an precise reference of when the executable was built.")))
+(define-public ocaml-xdg
+ (package
+ (inherit dune-ordering)
+ (name "ocaml-xdg")
+ (build-system dune-build-system)
+ (arguments
+ '(#:package "xdg"
+ ;; Tests have a cyclic dependency on stdune
+ #:tests? #f))
+ (propagated-inputs (list ocaml-odoc))
+ (synopsis "XDG Base Directory Specification library for ocaml")
+ (description
+ "This ocaml library returns user XDG directories such as XDG_CONFIG_HOME,
+ XDG_STATE_HOME.")))
+
(define-public ocaml-either
(package
(name "ocaml-either")