aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-01 21:46:20 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-11 19:15:10 +0100
commit9da142540eadd02443d6d671b0c9ed5414b23877 (patch)
tree9f358e82c83a341c6d368fd5dd6520d9794e0b83
parent5a33a71e678eeea5b27a3912f4dd7160528618fa (diff)
downloadguix-9da142540eadd02443d6d671b0c9ed5414b23877.tar.gz
guix-9da142540eadd02443d6d671b0c9ed5414b23877.zip
gnu: python-dolfin-adjoint: Adjust package style.
* gnu/packages/simulation.scm (python-dolfin-adjoint): Move inputs after arguments. [description]: Place it on a new line, fix indentation. Change-Id: I3d971e48b4072258ed0b41af5c202e64af9de8f3
-rw-r--r--gnu/packages/simulation.scm40
1 files changed, 20 insertions, 20 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index ab86e1d792..5341c0ae55 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -1204,17 +1204,6 @@ command-line utility for mesh optimisation.")
"tests/migration/viscoelasticity/test-results")
#t))))
(build-system python-build-system)
- (inputs
- (list fenics openmpi pybind11))
- (native-inputs
- (list pkg-config
- python-coverage
- python-decorator
- python-flake8
- python-pkgconfig
- python-pytest))
- (propagated-inputs
- `(("scipy" ,python-scipy)))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -1245,17 +1234,28 @@ command-line utility for mesh optimisation.")
;; fails with an ImportError if it sees that the backend module
;; has already been loaded.
(delete 'sanity-check))))
+ (inputs
+ (list fenics openmpi pybind11))
+ (native-inputs
+ (list pkg-config
+ python-coverage
+ python-decorator
+ python-flake8
+ python-pkgconfig
+ python-pytest))
+ (propagated-inputs
+ (list python-scipy))
(home-page "https://www.dolfin-adjoint.org")
(synopsis "Automatic differentiation library")
- (description "@code{python-dolfin-adjoint} is a solver of
-differential equations associated with a governing system and a
-functional of interest. Working from the forward model the solver
-automatically derives the discrete adjoint and tangent linear models.
-These additional models are key ingredients in many algorithms such as
-data assimilation, optimal control, sensitivity analysis, design
-optimisation and error estimation. The dolfin-adjoint project
-provides the necessary tools and data structures for cases where the
-forward model is implemented in @code{fenics} or
+ (description
+ "@code{python-dolfin-adjoint} is a solver of differential equations
+associated with a governing system and a functional of interest. Working from
+the forward model the solver automatically derives the discrete adjoint and
+tangent linear models. These additional models are key ingredients in many
+algorithms such as data assimilation, optimal control, sensitivity analysis,
+design optimisation and error estimation. The dolfin-adjoint project provides
+the necessary tools and data structures for cases where the forward model is
+implemented in @code{fenics} or
@url{https://firedrakeproject.org,firedrake}.")
(license license:lgpl3)))