aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-18 16:17:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:13 +0200
commit9b3e024d473c084e01e086ca3457a67e709ac86d (patch)
tree11fd3bfdcf3e245f4526f227694569ea91828716
parentef1e944c279cd3e27d79853237ce1049891fe6f6 (diff)
downloadguix-9b3e024d473c084e01e086ca3457a67e709ac86d.tar.gz
guix-9b3e024d473c084e01e086ca3457a67e709ac86d.zip
gnu: Add texlive-sepnum.
* gnu/packages/tex.scm (texlive-sepnum): New variable.
-rw-r--r--gnu/packages/tex.scm32
1 files changed, 27 insertions, 5 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 59207d3ec0..bcb41760c2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5225,17 +5225,39 @@ tuned to 21st-century presentation styles.")
(define-deprecated-package texlive-latex-seminar texlive-seminar)
+(define-public texlive-sepnum
+ (package
+ (name "texlive-sepnum")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/sepnum/" "tex/latex/sepnum/")
+ (base32
+ "1vzjhb470imd1f5wlj32jysn825vyygq9xkscqdjaa9jby70a26x")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/sepnum")
+ (synopsis "Print numbers in a friendly format")
+ (description
+ "This package provides a command to print a number with (potentially
+different) separators every three digits in the parts either side of the
+decimal point (the point itself is also configurable). The macro is fully
+expandable and not fragile (unless one of the separators is). There is also
+a command @code{\\sepnumform}, that may be used when defining
+@samp{\\the<counter> macros}.")
+ (license license:lppl)))
+
(define-public texlive-seqsplit
(package
(name "texlive-seqsplit")
(version (number->string %texlive-revision))
(source (texlive-origin
name version
- (list "doc/latex/seqsplit/"
- "source/latex/seqsplit/"
- "tex/latex/seqsplit/")
- (base32
- "0x6xcism9s9mhpr278xi4c1gimz3mlqnrpr40vkx5abglr0gzm0j")))
+ (list "doc/latex/seqsplit/"
+ "source/latex/seqsplit/"
+ "tex/latex/seqsplit/")
+ (base32
+ "0x6xcism9s9mhpr278xi4c1gimz3mlqnrpr40vkx5abglr0gzm0j")))
(outputs '("out" "doc"))
(build-system texlive-build-system)
(home-page "https://ctan.org/pkg/seqsplit")