aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2025-01-14 17:50:43 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2025-01-26 22:59:59 +0900
commit9ad90f5491a87d9ba9c004f7d74c0e788746a8c6 (patch)
treed5482b94d9ada37484dec2d1bd960406db953fb8
parenta895cc4c5bdb5d4bf8383077ef587ac18d069d7d (diff)
downloadguix-9ad90f5491a87d9ba9c004f7d74c0e788746a8c6.tar.gz
guix-9ad90f5491a87d9ba9c004f7d74c0e788746a8c6.zip
gnu: Add soundtouch-1/integer-samples.
* gnu/packages/audio.scm (soundtouch-1/integer-samples): New variable. Change-Id: Iea6e1313f2c7189ded9abf100f07ed530793f9f0 Reviewed-by: Sou Bunnbu (宋文武) <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/audio.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 76b16bc0fd..41d3d0bf47 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2016–2023 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2020, 2024 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 okapi <okapi@firemail.cc>
-;;; Copyright © 2018, 2020, 2022, 2023, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2018, 2020, 2022-2025 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2018, 2019, 2022 Marius Bakke <marius@gnu.org>
@@ -4409,6 +4409,30 @@ application developers writing sound processing tools that require tempo/pitch
control functionality, or just for playing around with the sound effects.")
(license license:lgpl2.1+)))
+(define-public soundtouch-1/integer-samples
+ (package
+ (inherit soundtouch)
+ (name "soundtouch")
+ (version "1.9.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/soundtouch/soundtouch.git")
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ir961w5gz86cm6yivr1ypi6n2y52vn319gy2gvdkkbbz5wyjkrq"))))
+ (arguments
+ ;; Dolphin expects the samples to be of the integer type.
+ (list #:configure-flags #~(list "--enable-integer-samples")
+ #:phases #~(modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ ;; Avoid the bootstrap script, which has a broken
+ ;; shebang.
+ (invoke "autoreconf" "-vif"))))))))
+
(define-public stargate-soundtouch
;; Stargate's fork of soundtouch.
(let ((commit "464f474c0be5d7e0970909dd30593012e4621468")