aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:02:14 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:33 +0200
commit9ad7cc6404f228e3d624a7151f70d2c6b0a36eea (patch)
tree927dc05c44d697303ea09bd2985fdbaf16b88228
parent63aa5ad665e6b10f2ba52973b3e2d4662b142a96 (diff)
downloadguix-9ad7cc6404f228e3d624a7151f70d2c6b0a36eea.tar.gz
guix-9ad7cc6404f228e3d624a7151f70d2c6b0a36eea.zip
gnu: Add texlive-svn-multi.
* gnu/packages/tex.scm (texlive-svn-multi): New variable.
-rw-r--r--gnu/packages/tex.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index fb90e1a701..a4ddf33d18 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -96871,6 +96871,34 @@ keywords. It is approximately an equivalent to the @code{rcs} package, but
for Subversion rather than CVS.")
(license license:lppl1.3+)))
+(define-public texlive-svn-multi
+ (package
+ (name "texlive-svn-multi")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/svn-multi/"
+ "doc/support/svn-multi/"
+ "scripts/svn-multi/"
+ "source/latex/svn-multi/"
+ "tex/latex/svn-multi/")
+ (base32
+ "1sfvp00c7bcql1hdmsmvc28jhngc553g8ldrjglvjp8gvcfpjww5")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "svn-multi.pl")))
+ (native-inputs (list texlive-ydoc))
+ (inputs (list perl))
+ (home-page "https://ctan.org/pkg/svn-multi")
+ (synopsis "Subversion keywords in multi-file LaTeX documents")
+ (description
+ "This package lets you typeset keywords of the version control system
+Subversion inside your LaTeX files anywhere you like. Unlike the otherwise
+similar package @code{svn}, the use of multiple files for one LaTeX document
+is well supported. The package interacts with an external Perl script, to
+retrieve information necessary for the required output.")
+ (license license:lppl)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar