aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-11-06 11:46:21 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-11-06 12:49:40 +0200
commit9aa17266dd72392138a746035cfbef78d5f9cb90 (patch)
treea0c552e7ac73e0c11a7dc8009817f1128360c6c4
parent143927acac99d187d2aa873e221d4f15cc1566ee (diff)
downloadguix-9aa17266dd72392138a746035cfbef78d5f9cb90.tar.gz
guix-9aa17266dd72392138a746035cfbef78d5f9cb90.zip
gnu: go-github-com-fxamacker-cbor-v2: Disable tests when cross-compiling.
* gnu/packages/golang-xyz.scm (go-github-com-fxamacker-cbor-v2) [arguments]: Also disable the tests when cross-compiling. Change-Id: If29c432399e59aed7947f513aa8c3a01315d30db
-rw-r--r--gnu/packages/golang-xyz.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 7989b2d767..c8db6ae479 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2766,7 +2766,8 @@ quoting, commenting, and escaping.")
;; XXX: Check if the most of the tests may be enabled:
;; src/github.com/fxamacker/cbor/v2/decode_test.go:328:9: cannot convert
;; 1000000000000 (untyped int constant) to type uint
- #:tests? (target-64bit?)
+ #:tests? (and (target-64bit?)
+ (not (%current-target-system)))
#:import-path "github.com/fxamacker/cbor/v2"))
(propagated-inputs
(list go-github-com-x448-float16))