aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2024-09-08 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2024-09-08 02:00:00 +0200
commit9a074d9f44ddfc67e95e6f9cbd4a99984fb70840 (patch)
treec1405a8112e8535a6bf8361c6bba8dadf567e58b
parenta2c462358e93b4ef2d16dadfc756fd73e5d526d1 (diff)
downloadguix-9a074d9f44ddfc67e95e6f9cbd4a99984fb70840.tar.gz
guix-9a074d9f44ddfc67e95e6f9cbd4a99984fb70840.zip
gnu: acpica: Use G-expressions.
* gnu/packages/admin.scm (acpica)[arguments]: Rewrite as G-expressions. Change-Id: I54fa79ac8008f7d8d41f9ebd757afcf7f5f1faf1
-rw-r--r--gnu/packages/admin.scm18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 2ccda10e27..129b1a0e43 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2518,12 +2518,16 @@ module slots, and the list of I/O ports (e.g. serial, parallel, USB).")
(build-system gnu-build-system)
(native-inputs (list flex bison))
(arguments
- `(#:make-flags (list (string-append "PREFIX=" %output)
- (string-append "CC=" ,(cc-for-target))
- "HOST=_LINUX"
- "OPT_CFLAGS=-Wall -fno-strict-aliasing")
- #:tests? #f ; no 'check' target
- #:phases (modify-phases %standard-phases (delete 'configure))))
+ (list
+ #:make-flags
+ #~(list (string-append "PREFIX=" #$output)
+ (string-append "CC=" #$(cc-for-target))
+ "HOST=_LINUX"
+ "OPT_CFLAGS=-Wall -fno-strict-aliasing")
+ #:tests? #f ;no test suite
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)))) ;no configure script
(home-page "https://acpica.org/")
(synopsis "Tools for the development and debugging of ACPI tables")
(description
@@ -2536,7 +2540,7 @@ debugging ACPI tables.
This package contains only the user-space tools needed for ACPI table
development, not the kernel implementation of ACPI.")
- (license license:gpl2))) ; dual GPLv2/ACPICA Licence
+ (license license:gpl2))) ;dual GPLv2/ACPICA Licence
(define-public s-tui
(package