aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 12:11:11 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:19 +0200
commit98eede996774ab6d680c15a077a60f3b1e254268 (patch)
tree1c128e0804facb76c9ccecfcbb1ee9e3551cf12f
parent1492c5a7de848b625fb2c37bad4b52642dd65180 (diff)
downloadguix-98eede996774ab6d680c15a077a60f3b1e254268.tar.gz
guix-98eede996774ab6d680c15a077a60f3b1e254268.zip
gnu: texlive-setspace: Refresh package definition.
* gnu/packages/tex.scm (texlive-setspace): Remove SIMPLE-TEXLIVE-PACKAGE call.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 12 insertions, 9 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 67918d7d5c..d0d2ef1345 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12312,22 +12312,25 @@ TikZ.")
(define-public texlive-setspace
(package
- (inherit
- (simple-texlive-package
- "texlive-setspace"
- (list "doc/latex/setspace/" "tex/latex/setspace/")
- (base32 "00ik8qgkw3ivh3z827zjf7gbwkbsmdcmv22c6ap543mpgaqqjcfm")
- #:trivial? #t))
+ (name "texlive-setspace")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/setspace/" "tex/latex/setspace/")
+ (base32
+ "00ik8qgkw3ivh3z827zjf7gbwkbsmdcmv22c6ap543mpgaqqjcfm")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
(home-page "https://ctan.org/pkg/setspace")
(synopsis "Set space between lines")
(description
- "The @code{setspace} package provides support for setting the spacing between
-lines in a document. Package options include @code{singlespacing},
+ "The @code{setspace} package provides support for setting the spacing
+between lines in a document. Package options include @code{singlespacing},
@code{onehalfspacing}, and @code{doublespacing}. Alternatively the spacing
can be changed as required with the @code{\\singlespacing},
@code{\\onehalfspacing}, and @code{\\doublespacing} commands. Other size
spacings also available.")
- (license license:lppl)))
+ (license license:lppl1.3+)))
(define-public texlive-pgfgantt
(package