aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2023-08-25 13:12:32 +0000
committerRicardo Wurmus <rekado@elephly.net>2023-08-28 10:38:07 +0200
commit9892efde37ab3577940664148c2f1a518a5f1fa1 (patch)
tree5060f63afceee5ebd408b2226724412ede07c5b3
parent458832c16eeb1038d6dbdc89167853d3143c2f86 (diff)
downloadguix-9892efde37ab3577940664148c2f1a518a5f1fa1.tar.gz
guix-9892efde37ab3577940664148c2f1a518a5f1fa1.zip
gnu: Add r-wrs2.
* gnu/packages/cran.scm (r-wrs2): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ec3b2f5c66..f04a8f9697 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -13344,6 +13344,30 @@ spreadsheet. The worksheet name will be the name of the data frame it
contains or can be specified by the user.")
(license license:gpl2+)))
+(define-public r-wrs2
+ (package
+ (name "r-wrs2")
+ (version "1.1-4")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "WRS2" version))
+ (sha256
+ (base32
+ "1838wy59cqd65s0bw6c24xcvx7zflypqcbgs35l9s2fj87vw2hdc"))))
+ (properties `((upstream-name . "WRS2")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-mass r-mc2d r-plyr r-reshape))
+ (native-inputs (list r-knitr))
+ (home-page "https://r-forge.r-project.org/projects/psychor/")
+ (synopsis "Collection of robust statistical methods")
+ (description
+ "R-wrs2 offers a range of strong stats methods from Wilcox WRS functions.
+It implements robust t-tests, both independent and dependent, robust ANOVA,
+including designs with between-within subjects, quantile ANOVA, robust
+correlation, robust mediation, and nonparametric ANCOVA models using robust
+location measures.")
+ (license license:gpl3)))
+
(define-public r-biasedurn
(package
(name "r-biasedurn")