aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-08 14:36:10 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:19 -0400
commit983ff32ad565c6c60bddc71aa15cdd5a6d1203cc (patch)
tree728e81f2d5a6ccfdb70e5791fcf4a20dcd896f30
parentab46c2cc0ba200dba9c2556581e66542601eb4e1 (diff)
downloadguix-983ff32ad565c6c60bddc71aa15cdd5a6d1203cc.tar.gz
guix-983ff32ad565c6c60bddc71aa15cdd5a6d1203cc.zip
gnu: ruby-addressable: Update to 2.8.1.
* gnu/packages/ruby.scm (ruby-addressable): Update to 2.8.1. [arguments]: Delete trailing #t. Add disable-bundler phase. [native-inputs]: Sort.
-rw-r--r--gnu/packages/ruby.scm34
1 files changed, 18 insertions, 16 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 71afa1f76a..57e646a65a 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -10644,38 +10644,40 @@ all known public suffixes.")
(define-public ruby-addressable
(package
(name "ruby-addressable")
- (version "2.7.0")
+ (version "2.8.1")
(source (origin
(method url-fetch)
(uri (rubygems-uri "addressable" version))
(sha256
(base32
- "1fvchp2rhp2rmigx7qglf69xvjqvzq7x0g49naliw29r2bz656sy"))))
+ "1ypdmpdn20hxp5vwxz3zc04r5xcwqc25qszdlg41h8ghdqbllwmw"))))
(build-system ruby-build-system)
(arguments
'(#:test-target "spec"
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'disable-bundler
+ (lambda _
+ (substitute* "spec/spec_helper.rb"
+ (("require 'bundler/setup'") ""))))
(add-after 'unpack 'remove-unnecessary-dependencies-from-Gemfile
- (lambda _
- (substitute* "Gemfile"
- (("git: 'https://github.com/sporkmonger/rack-mount.git',") "")
- ((".*launchy.*") "")
- ((".*rake.*") "gem 'rake'\n")
- ((".*redcarpet.*") ""))
- #t))
+ (lambda _
+ (substitute* "Gemfile"
+ (("git: 'https://github.com/sporkmonger/rack-mount.git',") "")
+ ((".*launchy.*") "")
+ ((".*rake.*") "gem 'rake'\n")
+ ((".*redcarpet.*") ""))))
(add-before 'check 'delete-network-dependent-test
(lambda _
- (delete-file "spec/addressable/net_http_compat_spec.rb")
- #t)))))
+ (delete-file "spec/addressable/net_http_compat_spec.rb"))))))
(native-inputs
- (list ruby-rspec
- bundler
+ (list bundler
ruby-idn-ruby
- ruby-sporkmonger-rack-mount
+ ruby-rspec
ruby-rspec-its-minimal
- ruby-yard
- ruby-simplecov))
+ ruby-simplecov
+ ruby-sporkmonger-rack-mount
+ ruby-yard))
(propagated-inputs
(list ruby-public-suffix))
(home-page "https://github.com/sporkmonger/addressable")