aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2023-07-30 11:19:01 -0300
committerVinicius Monego <monego@posteo.net>2023-09-30 10:37:47 -0300
commit962e246509febdef76efd7e94102e6b8ffb88ceb (patch)
treed936bb706836ee4ede7246abc0a20d1f4d7e88c0
parent65bcdd807d8f94122b86a86152678ddf85ee2414 (diff)
downloadguix-962e246509febdef76efd7e94102e6b8ffb88ceb.tar.gz
guix-962e246509febdef76efd7e94102e6b8ffb88ceb.zip
gnu: ceres: Propagate eigen and gflags.
* gnu/packages/maths.scm (ceres)[inputs]: Move eigen and gflags to ... [propagated-inputs]: ... here.
-rw-r--r--gnu/packages/maths.scm14
1 files changed, 4 insertions, 10 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 24fcd95493..68959ffbba 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2859,16 +2859,10 @@ with constraints.")
(substitute* "CMakeLists.txt"
(("set\\(LIB_SUFFIX \"64\"\\)")
"set(LIB_SUFFIX \"\")")))))))
- (native-inputs
- (list pkg-config))
- (propagated-inputs
- (list glog)) ;for #include <glog/glog.h>
- (inputs
- (list eigen
- openblas
- lapack
- suitesparse
- gflags))
+ (native-inputs (list pkg-config))
+ ;; These inputs need to be propagated to satisfy dependent packages.
+ (propagated-inputs (list eigen gflags glog))
+ (inputs (list openblas lapack suitesparse))
(synopsis "C++ library for solving large optimization problems")
(description
"Ceres Solver is a C++ library for modeling and solving large,