aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-14 14:39:10 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:02 +0200
commit95e4d69805e849ca2c79d5f2a4e47c02d3012f86 (patch)
tree5c7fa90a63be4367ef8d0845e7bd1f434b72f900
parent8cfcce51945fb48c2204c61a94836ede1e8c8425 (diff)
downloadguix-95e4d69805e849ca2c79d5f2a4e47c02d3012f86.tar.gz
guix-95e4d69805e849ca2c79d5f2a4e47c02d3012f86.zip
gnu: texlive-latex-examplep -> texlive-examplep.
* gnu/packages/tex.scm (texlive-examplep): New variable. (texlive-latex-examplep): Deprecate variable. * gnu/packages/bioinformatics.scm (discrover)[native-inputs]: Use new name.
-rw-r--r--gnu/packages/bioinformatics.scm2
-rw-r--r--gnu/packages/tex.scm55
2 files changed, 22 insertions, 35 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 742eb33a1c..66e84d2925 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4769,7 +4769,7 @@ data and settings.")
texlive-amsfonts
texlive-doi
texlive-ec
- texlive-latex-examplep
+ texlive-examplep
texlive-hyperref
texlive-ms
texlive-natbib
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b10d7eeb46..0f2246ae92 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9827,47 +9827,34 @@ in places where the standard @code{verbatim} environment (which is based on a
(define-deprecated-package texlive-latex-verbatimbox texlive-verbatimbox)
-(define-public texlive-latex-examplep
+(define-public texlive-examplep
(package
- (name "texlive-latex-examplep")
+ (name "texlive-examplep")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/latex/examplep"))
- (revision %texlive-revision)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "0fsvvmz68ij0zwfzrny6x13d92grxr4ap59lxgah4smbkccd6s27"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/tex/latex/examplep")))
- (mkdir-p target)
- (copy-recursively (assoc-ref %build-inputs "source") target)
- #t))))
- (home-page "https://www.ctan.org/pkg/examplep")
+ (source (texlive-origin
+ name version
+ (list "doc/latex/examplep/" "tex/latex/examplep/")
+ (base32
+ "0afbl77i57hxngc3l0czdzmmkhcgh2l4h2dpbg9ax9p9dv8c006n")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/examplep")
(synopsis "Verbatim phrases and listings in LaTeX")
(description
- "Examplep provides sophisticated features for typesetting verbatim source
-code listings, including the display of the source code and its compiled LaTeX
-or METAPOST output side-by-side, with automatic width detection and enabled
-page breaks (in the source), without the need for specifying the source twice.
-Special care is taken that section, page and footnote numbers do not interfere
-with the main document. For typesetting short verbatim phrases, a replacement
-for the @code{\\verb} command is also provided in the package, which can be
-used inside tables and moving arguments such as footnotes and section
-titles.")
+ "The @code{examplep} package provides sophisticated features for
+typesetting verbatim source code listings, including the display of the source
+code and its compiled LaTeX or METAPOST output side-by-side, with automatic
+width detection and enabled page breaks (in the source), without the need for
+specifying the source twice. Special care is taken that section, page and
+footnote numbers do not interfere with the main document. For typesetting
+short verbatim phrases, a replacement for the @code{\\verb} command is also
+provided in the package, which can be used inside tables and moving arguments
+such as footnotes and section titles.")
;; No version of the GPL is specified.
(license license:gpl3+)))
+(define-deprecated-package texlive-latex-examplep texlive-examplep)
+
(define-public texlive-xunicode
(package
(inherit