aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2023-06-04 17:42:05 +0000
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-22 13:12:38 +0100
commit95b4594a2ed19e6e1553a1b2a581391ef1b8eaa3 (patch)
tree55cbcc2b3c070f34fa86a6d365e6d1dd997b7ff2
parent2b6d46c8de2974ae1936be5cde556a778ea5e860 (diff)
downloadguix-95b4594a2ed19e6e1553a1b2a581391ef1b8eaa3.tar.gz
guix-95b4594a2ed19e6e1553a1b2a581391ef1b8eaa3.zip
gnu: Add perl-test-fork.
* gnu/packages/perl-check.scm (perl-test-fork): New variable. Signed-off-by: Danny Milosavljevic <dannym@friendly-machines.com>
-rw-r--r--gnu/packages/perl-check.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index 44bbc2fcc6..7672e82f9b 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -736,6 +736,29 @@ and directories. For instance, the @code{file_ok} helper can test whether the
contents of a file is equal to a particular string.")
(license perl-license)))
+(define-public perl-test-fork
+ (package
+ (name "perl-test-fork")
+ (version "0.02")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MS/MSCHWERN/Test-Fork-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0gnh8m81fdrwmzy1fix12grfq7sf7nn0gbf24zlap1gq4kxzpzpw"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-module-build))
+ (home-page "https://metacpan.org/release/Test-Fork")
+ (synopsis "Test code which forks")
+ (description
+ "Testing code which forks is problematic because each test has a number
+associated with it. Coordinating the test number amongst the parent and child
+processes is complicated. @code{Test::Fork} provides a function to smooth over
+the complications.")
+ (license perl-license)))
+
(define-public perl-test-harness
(package
(name "perl-test-harness")