aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-03-11 10:48:26 -0400
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:59 +0200
commit93f34e32359ad373dae1c22fc3dfecd0927702b1 (patch)
tree89dc1e5bdf717f620fe04e7d33f0ded36e927ada
parent687751d0d89454395cdc96d1370c1388a7c762f5 (diff)
downloadguix-93f34e32359ad373dae1c22fc3dfecd0927702b1.tar.gz
guix-93f34e32359ad373dae1c22fc3dfecd0927702b1.zip
gnu: kmod: Modernize.
* gnu/packages/linux.scm (kmod) [native-inputs, inputs]: Remove labels. [arguments]: Use gexps, remove trailing #t. Change-Id: If40e25d38c5b4ac3cb192a76d688834069278c9d
-rw-r--r--gnu/packages/linux.scm50
1 files changed, 20 insertions, 30 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index baaf62b636..010af264a7 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4330,37 +4330,27 @@ to use Linux' inotify mechanism, which allows file accesses to be monitored.")
"0am54mi5rk72g5q7k6l6f36gw3r9vwgjmyna43ywcjhqmakyx00b"))
(patches (search-patches "kmod-module-directory.patch"))))
(build-system gnu-build-system)
- (native-inputs
- (list pkg-config
- ;; For tests.
- zstd))
- (inputs
- `(("xz" ,xz)
- ("zlib" ,zlib)
- ("zstd-lib" ,zstd "lib")))
(arguments
- `(#:configure-flags '("--with-xz" "--with-zlib" "--with-zstd"
- "--disable-test-modules")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'disable-tests
- (lambda _
- ;; XXX: These tests need '--sysconfdir=/etc' to pass.
- (substitute* "Makefile.in"
- (("testsuite/test-modprobe") "")
- (("testsuite/test-depmod") "")
- (("testsuite/test-blacklist") ""))
- #t))
- (add-after 'install 'install-modprobe&co
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (for-each (lambda (tool)
- (symlink "kmod"
- (string-append bin "/" tool)))
- '("insmod" "rmmod" "lsmod" "modprobe"
- "modinfo" "depmod"))
- #t))))))
+ (list #:configure-flags #~(list "--with-xz" "--with-zlib" "--with-zstd"
+ "--disable-test-modules")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-tests
+ (lambda _
+ ;; XXX: These tests need '--sysconfdir=/etc' to pass.
+ (substitute* "Makefile.in"
+ (("testsuite/test-modprobe") "")
+ (("testsuite/test-depmod") "")
+ (("testsuite/test-blacklist") ""))))
+ (add-after 'install 'install-modprobe&co
+ (lambda _
+ (for-each (lambda (tool)
+ (symlink "kmod"
+ (string-append #$output "/bin/" tool)))
+ '("insmod" "rmmod" "lsmod" "modprobe"
+ "modinfo" "depmod")))))))
+ (native-inputs (list pkg-config zstd)) ;zstd needed for tests
+ (inputs (list xz zlib `(,zstd "lib")))
(supported-systems (delete "i586-gnu" %supported-systems))
(home-page "https://www.kernel.org/")
(synopsis "Kernel module tools")