aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAshvith Shetty <ashvithshetty0010@zohomail.in>2025-02-15 00:35:27 +0530
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-02-15 16:03:12 +0000
commit93a59ab4e0ba3c2299bfe3220866172b0882aff9 (patch)
tree9642a6da7b14c03c5b491943f301b55b65cce0d8
parentae85e8303c850c4bf0e268f7420be24717207f41 (diff)
downloadguix-93a59ab4e0ba3c2299bfe3220866172b0882aff9.tar.gz
guix-93a59ab4e0ba3c2299bfe3220866172b0882aff9.zip
gnu: Add go-github-com-zyedidia-clipper.
* gnu/packages/golang-xyz.scm (go-github-com-zyedidia-clipper): New variable. Change-Id: Ib97afc64f6186034239b2c55454413d8033c1be1 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 9c78ea793f..469db685d1 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -15960,6 +15960,40 @@ configuration languages, but other uses may be possible too.")
utilities for cty Golang module.")
(license license:expat)))
+(define-public go-github-com-zyedidia-clipper
+ (package
+ (name "go-github-com-zyedidia-clipper")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zyedidia/clipper")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18fv2cdll1d7d5wxs6r7kkhmk60pziiw3iy7knmdbcbhrk9rg112"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/zyedidia/clipper"))
+ (home-page "https://github.com/zyedidia/clipper")
+ (synopsis "Clipboard access in Golang")
+ (description
+ "This package provides a cross-platform clipboard library.
+
+Platforms supported:
+@itemize
+@item Linux via @code{xclip} or @code{xsel} or @code{wl-copy/wl-paste}
+@item MacOS via @code{pbcopy/pbpaste}
+@item Windows via the Windows clipboard API
+@item WSL via clip.exe/powershell.exe
+@item Android Termux via @code{termux-clipboard-set/termux-clipboard-get}
+@item Plan9 via @code{/dev/snarf}
+@item Anything else via a user-defined script
+@end itemize")
+ (license (list license:expat license:bsd-3))))
+
(define-public go-github-com-zyedidia-poller
(package
(name "go-github-com-zyedidia-poller")