aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@friendly-machines.com>2025-02-14 17:14:51 +0100
committerDanny Milosavljevic <dannym@friendly-machines.com>2025-02-14 17:16:28 +0100
commit93551174af7a96d61f22f013ad1b9935106bf040 (patch)
treefdc465b01060ddd1f4e907fc78810ed6ba1471cb
parentf7fb297f2dc59b8d0da7a18b1f69ec550398f734 (diff)
downloadguix-93551174af7a96d61f22f013ad1b9935106bf040.tar.gz
guix-93551174af7a96d61f22f013ad1b9935106bf040.zip
gnu: openrgb: Support wayland.
* gnu/packages/hardware.scm (openrgb)[inputs]: Add qtwayland-5. [build-system]: Switch to qt-build-system. Change-Id: I9877876315af280fbe2b53b45bdc89012ffc22ed
-rw-r--r--gnu/packages/hardware.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 5c84531216..9ef98a17c0 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -108,6 +108,7 @@
#:use-module (guix build-system perl)
#:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
+ #:use-module (guix build-system qt)
#:use-module (guix download)
#:use-module (guix gexp)
#:use-module (guix git-download)
@@ -1142,7 +1143,7 @@ technology, such as head mounted displays with built in head tracking.")
"dependencies/winring0"
;; Some bundled appimages
"scripts/tools"))))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(arguments
(list
#:tests? #f ; doesn't have tests
@@ -1174,7 +1175,8 @@ technology, such as head mounted displays with built in head tracking.")
nlohmann-json
libusb
mbedtls-lts
- qtbase-5))
+ qtbase-5
+ qtwayland-5))
(native-inputs
(list pkg-config
qttools-5))