aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 17:11:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:28 +0200
commit9272f0576adc7b2508e6cfb12c5b370853dcc2ee (patch)
treeae5d64207ae4161619138e5836d6180bb0b4a8f0
parent5848b9ddb34b9ba7c7486fcdb6605ae0f130f169 (diff)
downloadguix-9272f0576adc7b2508e6cfb12c5b370853dcc2ee.tar.gz
guix-9272f0576adc7b2508e6cfb12c5b370853dcc2ee.zip
gnu: texlive-ly1: Refresh package definition.
* gnu/packages/tex.scm (texlive-ly1): Remove SIMPLE-TEXLIVE-PACKAGE call.
-rw-r--r--gnu/packages/tex.scm38
1 files changed, 21 insertions, 17 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 14fb322865..5c7e9bd976 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11333,24 +11333,28 @@ Type 1 and OTF formats, with supporting files as necessary.")
(define-public texlive-ly1
(package
- (inherit (simple-texlive-package
- "texlive-ly1"
- (list "/doc/fonts/ly1/"
- "/fonts/enc/dvips/ly1/"
- "/fonts/map/dvips/ly1/"
- "/fonts/tfm/adobe/ly1/"
- "/fonts/vf/adobe/ly1/"
- "/tex/latex/ly1/")
- (base32
- "0wjyw0risgvrq97zfciglwy1f4msvfslln6pz0q8yzzx8wsv3zgq")
- #:trivial? #t))
- (home-page "https://www.ctan.org/pkg/ly1")
+ (name "texlive-ly1")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/ly1/"
+ "fonts/enc/dvips/ly1/"
+ "fonts/map/dvips/ly1/"
+ "fonts/tfm/adobe/ly1/"
+ "fonts/vf/adobe/ly1/"
+ "tex/latex/ly1/"
+ "tex/plain/ly1/")
+ (base32
+ "1lks902rr94m3n3r4rc2lm4vvqhqv9prgrpni5ww64rqrv56h8yy")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/ly1")
(synopsis "Support for LY1 LaTeX encoding")
- (description "The legacy @emph{texnansi} (TeX and ANSI) encoding
-is known in the LaTeX scheme of things as @emph{LY1} encoding. The
-@code{ly1} bundle includes metrics and LaTeX macros to use the three
-basic Adobe Type 1 fonts (Times, Helvetica and Courier) in LaTeX using
-LY1 encoding.")
+ (description
+ "The legacy @code{texnansi} (TeX and ANSI) encoding is known in the LaTeX
+scheme of things as @emph{LY1} encoding. The @code{ly1} bundle includes
+metrics and LaTeX macros to use the three basic Adobe Type 1 fonts (Times,
+Helvetica and Courier) in LaTeX using LY1 encoding.")
(license license:lppl1.0+)))
(define-public texlive-sectsty