aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-08-09 23:33:55 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-08-20 11:50:46 +0800
commit921b4ed19594758ee16e7320f607a4a9ca454557 (patch)
tree4dc787e06f692612faf5e269873e5f76d9e2a75e
parentbc4442261fcd74a7f584cb00a42d9e8192ff06df (diff)
downloadguix-921b4ed19594758ee16e7320f607a4a9ca454557.tar.gz
guix-921b4ed19594758ee16e7320f607a4a9ca454557.zip
gnu: plasma-workspace: Update to 6.1.4.
* gnu/packages/kde-plasma.scm (plasma-workspace): Update to 6.1.4. [arguments]<#:phases>: Add add-span-header phase. Change-Id: Ifc5e82532b569148ab00ab2f1463c65fa507d73d
-rw-r--r--gnu/packages/kde-plasma.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index b70d5aa3ab..7c5efa41ea 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -2698,14 +2698,14 @@ sensors, process information and other system resources.")
(define-public plasma-workspace
(package
(name "plasma-workspace")
- (version "6.1.3")
+ (version "6.1.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/plasma/" version
"/" name "-" version ".tar.xz"))
(sha256
(base32
- "1jnmqj16ivi2qv3q9i5fggknaw85drf216ml7ckvfvc5abxxx73r"))))
+ "0mlddkjxq7p01wgy8pzp65fhg1sihibzd32wn3s3zcn077frj86b"))))
(build-system qt-build-system)
(native-inputs (list extra-cmake-modules kdoctools pkg-config qtsvg
qttools
@@ -2824,6 +2824,12 @@ sensors, process information and other system resources.")
"/libexec/kglobalacceld"))
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'add-span-header
+ (lambda _
+ (substitute* "xembed-sni-proxy/sniproxy.cpp"
+ (("#include \"sniproxy.h\"")
+ (string-append "#include \"sniproxy.h\"
+#include <span>")))))
(add-after 'unpack 'patch-workspace-bins
(lambda* (#:key inputs #:allow-other-keys)
(let ((xmessage (search-input-file inputs "/bin/xmessage"))