aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-11-06 11:37:34 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-11-06 12:49:39 +0200
commit9183e61ad14eb784e98afcd7494b9ed17a75ecaa (patch)
treea128ac99e6bf57c554113de0f7d5bbd154a6793d
parentb6487f8d5a4735d73e2a9730652ea5a4d777b776 (diff)
downloadguix-9183e61ad14eb784e98afcd7494b9ed17a75ecaa.tar.gz
guix-9183e61ad14eb784e98afcd7494b9ed17a75ecaa.zip
gnu: ngspice: Don't inherit #:tests flag.
* gnu/packages/engineering.scm (ngspice)[arguments]: Adjust the inherited arguments to not inherit the #:tests setting. Change-Id: Ia8d5b1e615a0683cfc438796b6c2f97642de724f
-rw-r--r--gnu/packages/engineering.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 6f449f0c39..4ba28ca9b4 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2092,8 +2092,10 @@ an embedded event driven algorithm.")
(inherit libngspice)
(name "ngspice")
(arguments
- (substitute-keyword-arguments (package-arguments libngspice)
- ((#:tests? _ #f) #t)
+ (substitute-keyword-arguments
+ (strip-keyword-arguments
+ (list #:tests?)
+ (package-arguments libngspice))
((#:configure-flags flags)
#~(cons "--with-readline=yes"
(delete "--with-ngshared"