aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:54:13 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:56 +0000
commit910c1ee7ce163b8d4c3bc6d15c645be34b46a9c2 (patch)
tree52503292a7700dbf4d1597ecf727dbd63bc5cb48
parenta60366ca06e8cc004fa4524b5f834130f776e8e6 (diff)
downloadguix-910c1ee7ce163b8d4c3bc6d15c645be34b46a9c2.tar.gz
guix-910c1ee7ce163b8d4c3bc6d15c645be34b46a9c2.zip
gnu: borgmatic: Move to pyproject-build-system.
* gnu/packages/backup.scm (borgmatic): [build-system]: Move to pyproject-build-system. [arguments]: Migrate 'check phase replacement to <#:test-flags>. <#:phases>: Add 'set-path phase. Change-Id: I916e87f10c75718c4e840d97eaa78623ed2a4fd3 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/backup.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 281f951f78..12ee64e9dd 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Feng Shu <tumashu@163.com>
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
+;;; Copyright © 2024 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2024 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
@@ -1334,7 +1335,7 @@ compression parameters used by Gzip.")
(uri (pypi-uri "borgmatic" version))
(sha256
(base32 "0im7kx9mq1gymid88wa6yxcif4bdqpz5lag5fp9kpm8r5k13p2sr"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
(list
#:phases #~(modify-phases %standard-phases
@@ -1351,14 +1352,12 @@ compression parameters used by Gzip.")
(string-append start "'"
(search-input-file inputs "bin/borg")
"'")))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
+ (add-before 'check 'set-path
+ (lambda _
;; Tests require the installed executable.
(setenv "PATH"
(string-append #$output "/bin" ":"
- (getenv "PATH")))
- (invoke "pytest")))))))
+ (getenv "PATH"))))))))
(inputs (list borg
python-apprise
python-colorama