aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-17 19:48:05 +0000
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:24 +0100
commit908b9b27e5b3631ca41b62dfb0b0e2b0eb5501cc (patch)
tree4754ef0833c4060b38b3d2e02a7d38ca14904d0f
parent1ebc72c32316f50ccdb43557b3fe8cfdcef7702d (diff)
downloadguix-908b9b27e5b3631ca41b62dfb0b0e2b0eb5501cc.tar.gz
guix-908b9b27e5b3631ca41b62dfb0b0e2b0eb5501cc.zip
gnu: python-email-validator: Update to 2.2.0.
* gnu/packages/python-xyz.scm (python-email-validator): Update to 2.2.0. Improve style. [build-system]: Swap to pyrpoject-build-system. [arguments]<test-flags>: Skip one test. <phases>: Remove 'use-dnspython as removed in <https://github.com/JoshData/python-email-validator/pull/13>. [native-inputs]: Add python-pytest, python-setuptools, and python-wheel. Change-Id: Idc51ad58fe734071aa66f44bce0fb7cbf84831b6
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 17 insertions, 15 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1416c2f3c7..cfccf0c63f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23067,24 +23067,26 @@ simple, lightweight implementation.")
(define-public python-email-validator
(package
(name "python-email-validator")
- (version "1.0.2")
+ (version "2.2.0")
(source
- (origin (method url-fetch)
- (uri (pypi-uri "email_validator" version))
- (sha256
- (base32
- "1ja9149l9ck5n45a72h3is7v476hjny5ybxbcamx1nw6iplsm7k6"))))
- (build-system python-build-system)
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "email_validator" version))
+ (sha256
+ (base32 "1dw28lv9lpsw2s7dylhih93fn72s8iqyfsp6497p2yk19hs0ysfb"))))
+ (build-system pyproject-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-before 'build 'use-dnspython
- (lambda _
- (substitute* "setup.py"
- (("dnspython3") "dnspython"))
- #t)))))
+ (list
+ #:test-flags
+ ;; dns.resolver.NoResolverConfiguration: cannot open /etc/resolv.conf
+ #~(list "-k" "not test_caching_dns_resolver")))
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
(propagated-inputs
- (list python-dnspython python-idna))
+ (list python-dnspython
+ python-idna))
(home-page "https://github.com/JoshData/python-email-validator")
(synopsis "Email address validation library for Python")
(description