aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-02-18 22:02:30 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:40:53 +0300
commit90706559fe168128c43e35869f5392e3d6379d51 (patch)
tree3ee2d390e2a2dfed87af576749f704abc484b9b5
parentb4b59049d6b800b9e59b7158d01086eaf935ab31 (diff)
downloadguix-90706559fe168128c43e35869f5392e3d6379d51.tar.gz
guix-90706559fe168128c43e35869f5392e3d6379d51.zip
gnu: Add rust-eyeball-im-util-0.5.
* gnu/packages/crates-io.scm (rust-eyeball-im-util-0.5): Add variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Change-Id: Ie02a9d26cb5ac5155d2bc450a8b796bed2052f0d
-rw-r--r--gnu/packages/crates-io.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e072fa3584..6fbc0a6c57 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -22618,6 +22618,35 @@ like Don libes expect.")
(description "Observable collections based on the `im` crate.")
(license license:mpl2.0)))
+(define-public rust-eyeball-im-util-0.5
+ (package
+ (name "rust-eyeball-im-util")
+ (version "0.5.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "eyeball-im-util" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0q4r3qi46s8mnvn2y9pk322y4qdl4j81pa53q7xg4c9zncma5zn0"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-arrayvec" ,rust-arrayvec-0.7)
+ ("rust-eyeball-im" ,rust-eyeball-im-0.4)
+ ("rust-futures-core" ,rust-futures-core-0.3)
+ ("rust-imbl" ,rust-imbl-2)
+ ("rust-pin-project-lite" ,rust-pin-project-lite-0.2)
+ ("rust-smallvec" ,rust-smallvec-1))
+ #:cargo-development-inputs
+ (("rust-eyeball" ,rust-eyeball-0.8)
+ ("rust-futures-util" ,rust-futures-util-0.3)
+ ("rust-stream-assert" ,rust-stream-assert-0.1)
+ ("rust-tokio" ,rust-tokio-1))))
+ (home-page "https://github.com/jplatte/eyeball")
+ (synopsis "Helpful utilities for `eyeball-im`")
+ (description "Helpful utilities for `eyeball-im`.")
+ (license license:mpl2.0)))
+
(define-public rust-eyre-0.6
(package
(name "rust-eyre")
209ceca9972dcd375d2a0f869abc6d1f26'>bash completion: Append to $COMPREPLY where possible...._guix_complete is always called with a fresh empty array. * etc/completion/bash/guix (_guix_complete_command) (_guix_complete_subcommand, _guix_complete_installed_package) (_guix_complete_option, _guix_complete_pid): Append to $COMPREPLY rather than re-assigning. Tobias Geerinckx-Rice 2021-10-03bash completion: Consolidate similar $command ‘if’ branches....* etc/completion/bash/guix (_guix_complete): Combine the ‘upgrade’ and ‘remove’ commands, as well as ‘download’, ‘gc’, and ‘hash’. Tobias Geerinckx-Rice 2021-06-16bash_completion: Complete options for ‘guix environment’....Note that there are still plenty of bugs that this series didn't fix, e.g.: $ guix time-machine -- system reconf<Tab> * etc/completion/bash/guix (_guix_complete): Call _guix_complete_option if the word at point looks like an option. Tobias Geerinckx-Rice 2021-06-16bash completion: Complete options for the right command....* etc/completion/bash/guix (_guix_complete_option): Receive two arguments and complete the second based on the first, instead of blindly completing the very last word based on the very first (sub)command. (_guix_complete): Adjust both calls. Tobias Geerinckx-Rice 2021-06-16bash completion: Really support subcommands....* etc/completion/bash/guix (_guix_is_option): New function. (_guix_is_command): Remove function to replace it with simple string comparison… (_guix_complete): …here. Complete the ‘innermost’ command at point. Tobias Geerinckx-Rice 2020-12-04bash completion: Complete file names after '-f' and '-l'....* etc/completion/bash/guix (_guix_is_dash_f, _guix_is_dash_l): New functions. (_guix_complete): Complete file names after 'guix package -f', 'guix build -f', and 'guix environment -l'. Ludovic Courtès 2020-09-24bash completion: Adjust to new 'guix help' output....This is a followup to 3794ce93be8216d8378df7b808ce7f53b1e05a53, which broke command completion. Reported by Oleg Pykhalov <go.wigust@gmail.com>. * etc/completion/bash/guix (_guix_complete_command): Update to match output of 'guix help' as introduced in 3794ce93be8216d8378df7b808ce7f53b1e05a53. Ludovic Courtès 2020-09-21bash completion: Complete file names after 'guix package -p'....* etc/completion/bash/guix (_guix_complete): Add _guix_is_dash_p. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Fulbert 2020-09-10bash completion: Restore completion for 'guix system', etc....Commit 538ca8dd65f0075cc65bcca18ed87f66a789290a introduced a second '_guix_complete_subcommand' function, shadowing the existing one, which broke sub-command completion for 'guix system', 'guix import', etc. * etc/completion/bash/guix: Distinguish between '_guix_complete_command' and '_guix_complete_subcommand'. Adjust users to call the right one. Ludovic Courtès 2020-06-27bash completion: Complete 'guix environment' properly....* etc/completion/bash/guix (_guix_complete): Add case for "guix environment". Ludovic Courtès 2020-06-04bash completion: Complete sub-commands after 'guix time-machine'....* etc/completion/bash/guix (_guix_complete_subcommand): New function. (_guix_complete): Use it. For "time-machine", call '_guix_complete_subcommand' by default. Ludovic Courtès 2020-06-04bash completion: Complete file names after '-p' and '-C'....* etc/completion/bash/guix (_guix_is_dash_C, _guix_is_dash_p): New functions. (_guix_complete): Honor them for "install", "remove", "upgrade", "pull", and "time-machine". Ludovic Courtès 2020-02-14guix build: Add '--manifest' option....* guix/scripts/build.scm (show-help): Document --manifest argument. (options->things-to-build): When given a manifest, evaluate all the entries. * tests/guix-build.sh: Add test for --manifest. * doc/guix.texi (Additional Build Options): Mention --manifest. * etc/completion/bash/guix: Complete file name if 'guix build' argument is -m. Marius Bakke 2019-04-29guix package: Add 'install', 'remove', and 'upgrade' aliases....* guix/scripts/install.scm, guix/scripts/remove.scm, guix/scripts/upgrade.scm, tests/guix-package-aliases.sh: New files. * Makefile.am (MODULES, SH_TESTS): Add them. * po/guix/POTFILES.in: Add them. * guix/scripts/package.scm (guix-package): Split with... (guix-package*): ... this. New procedure. * doc/guix.texi (Invoking guix package): Document them. (Binary Installation, Application Setup, Package Management) (Packages with Multiple Outputs, Package Modules) (X.509 Certificates, Installing Debugging Files): Use 'guix install' in simple examples. * etc/completion/bash/guix (_guix_complete): Handle "install", "remove", and "upgrade". Ludovic Courtès 2018-11-06bash completion: Restore completion of available packages for 'guix build'....Fixes a regression introduced in 9b0a755f642542dd96065ad05ec9d844d8077fd7 whereby 'guix build TAB' would not suggest any completion. * etc/completion/bash/guix (_guix_complete): Arrange so 'guix build TAB' completes available packages. Ludovic Courtès 2018-07-03bash completion: Complete files names after 'guix weather -m'....* etc/completion/bash/guix (_guix_complete): Complete files names after 'guix weather -m'. Oleg Pykhalov 2018-07-03bash completion: Complete files names after 'guix build -L'....* etc/completion/bash/guix (_guix_complete): Complete files names after 'guix build -L'. Oleg Pykhalov 2018-06-16Add guix-daemon Bash completion file....* etc/completion/bash/guix-daemon: New file. * Makefile.am (dist_bashcompletion_DATA): Add this. Oleg Pykhalov 2018-02-17bash completion: Complete files names after 'guix package -m'....* etc/completion/bash/guix (_guix_is_dash_m): New function. (_guix_complete): Add this. Oleg Pykhalov 2017-08-22bash completion: Complete files names after 'guix download'....* etc/completion/bash/guix (_guix_complete): When the command is "download", use __guix_complete_file. Marius Bakke