aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-09-13 22:19:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-09-13 22:19:23 +0200
commit9049506d8b11a4f77f207827cd8667e0dedeaeb2 (patch)
treeba0dcf68836fb21816ed0ed2cec3f6c0b86eb6d6
parentbf982837412f271f74b148b22ff5ec4d107e045f (diff)
downloadguix-9049506d8b11a4f77f207827cd8667e0dedeaeb2.tar.gz
guix-9049506d8b11a4f77f207827cd8667e0dedeaeb2.zip
gnu: python-hicmatrix: Remove custom 'check phase.
* gnu/packages/bioinformatics.scm (python-hicmatrix)[arguments]: Remove custom 'check phase.
-rw-r--r--gnu/packages/bioinformatics.scm6
1 files changed, 1 insertions, 5 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1ceb429169..aa88692204 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -16232,11 +16232,7 @@ includes operations like compartment, insulation or peak calling.")
(add-after 'unpack 'remove-invalid-syntax
(lambda _
(substitute* "setup.py"
- ((".\\*\"") "\""))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "python" "-m" "pytest" "-v")))))))
+ ((".\\*\"") "\"")))))))
(propagated-inputs
(list python-cooler
python-intervaltree