aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@friendly-machines.com>2024-12-17 16:49:41 +0100
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-17 17:02:59 +0100
commit8e1191472c0d862632d0067b7938feb43dddf64d (patch)
tree762e3d1eea122c1377be909aebea107d7379d1e8
parent907590b67139f18dd33dab3f9bee29b9a08c6829 (diff)
downloadguix-8e1191472c0d862632d0067b7938feb43dddf64d.tar.gz
guix-8e1191472c0d862632d0067b7938feb43dddf64d.zip
gnu: python-stsci-imagestats: Fix build.
* gnu/packages/astronomy.scm (python-stsci-imagestats)[native-inputs]: Add python-setuptools, python-wheel. Change-Id: I3a788e066cdbba59983b1cdb0e81c7dc5733d7a5
-rw-r--r--gnu/packages/astronomy.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index df2a824beb..0a9eaa4fed 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -5159,7 +5159,8 @@ Telescope Science Institute} image array manipulation functions.")
;; Cython extensions have to be built before running the tests.
(invoke "python" "setup.py" "build_ext" "--inplace"))))))
(propagated-inputs (list python-numpy))
- (native-inputs (list python-pytest python-setuptools-scm))
+ (native-inputs (list python-pytest python-setuptools python-wheel
+ python-setuptools-scm))
(home-page "https://stsciimagestats.readthedocs.io/en/latest/")
(synopsis "Compute sigma-clipped statistics on data arrays")
(description