aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@friendly-machines.com>2024-12-12 00:30:09 +0100
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-12 00:30:09 +0100
commit8b65fdc182e7340946be8b1e7b688d03b96c3482 (patch)
treec6fc8e7b1e59b7c9902fd9f1a24375eeae98c22f
parent942dd1700dcc8bfc45baa1c29357c7977e03c763 (diff)
downloadguix-8b65fdc182e7340946be8b1e7b688d03b96c3482.tar.gz
guix-8b65fdc182e7340946be8b1e7b688d03b96c3482.zip
gnu: Add python-mathics-django.
* gnu/packages/maths.scm (python-mathics-django): New variable. Change-Id: I9f928a13e07f4fc680a6d0e3e965a72d45d7d80c
-rw-r--r--gnu/packages/maths.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index d244f1c1e1..60203f82a9 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -125,6 +125,7 @@
#:use-module (gnu packages datamash)
#:use-module (gnu packages dbm)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages django)
#:use-module (gnu packages elf)
#:use-module (gnu packages emacs)
#:use-module (gnu packages file)
@@ -10609,3 +10610,35 @@ to Wolfram.")
(description "This package provides a command-line interface to
Mathics3.")
(license license:gpl3)))
+
+(define-public python-mathics-django
+ (package
+ (name "python-mathics-django")
+ (version "7.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Mathics-Django" version))
+ (sha256
+ (base32 "02ccq0kx9i9b339p48j6xixr5wqj58dp8rhcik07b7vrfvznnxdi"))))
+ (build-system pyproject-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'build 'check
+ (lambda _
+ (setenv "PYTHONPATH" (getcwd))
+ (setenv "DJANGO_SETTINGS_MODULE" "mathics_django.settings")
+ (invoke "django-admin" "test"))))))
+ (native-inputs (list python-pytest))
+ (propagated-inputs (list python-django-4.2
+ python-mathics-scanner
+ python-mathics-core
+ python-networkx-next
+ python-pygments
+ python-requests))
+ (home-page "https://mathics.org/")
+ (synopsis "A Django front end for Mathics3.")
+ (description "This package provides a Django front end for Mathics3.")
+ (license license:gpl3)))