aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2022-11-28 09:07:33 +0100
committerLudovic Courtès <ludo@gnu.org>2023-01-05 22:18:40 +0100
commit8b3d0b1849404d8ecc9a6bc42562839c13556c6c (patch)
tree18425fd46b558b0ca8c0362f95981996efb6a687
parente7da6dd6d653d8edb35079f3aeb345406e20bea7 (diff)
downloadguix-8b3d0b1849404d8ecc9a6bc42562839c13556c6c.tar.gz
guix-8b3d0b1849404d8ecc9a6bc42562839c13556c6c.zip
gnu: Add emacs-ibrowse.
* gnu/packages/emacs-xyz.scm (emacs-ibrowse): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7a94a674fa..b5c2c011db 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21991,6 +21991,30 @@ key again.")
within Emacs.")
(license license:gpl3+))))
+(define-public emacs-ibrowse
+ (let* ((commit "7e4a2987fc63861514b441f65db2008da5949ef2")
+ (revision "0"))
+ (package
+ (name "emacs-ibrowse")
+ (version (git-version "0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~ngraves/ibrowse.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15661xgjxdxk1p0g87dsas9jd9v7g64y6n9irlbyzww09gjsjwwd"))))
+ (build-system emacs-build-system)
+ (inputs (list sqlite))
+ (propagated-inputs (list emacs-embark emacs-marginalia))
+ (home-page "https://git.sr.ht/~ngraves/ibrowse.el")
+ (synopsis "Interact with your browser from emacs")
+ (description "This package provides some commands to act on the browser
+tabs, history, or bookmarks from Emacs.")
+ (license license:gpl3+))))
+
(define-public emacs-ibuffer-projectile
(package
(name "emacs-ibuffer-projectile")