aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2024-11-03 13:03:48 +0100
committerJelle Licht <jlicht@fsfe.org>2024-12-18 22:02:19 +0100
commit89b8a6d27da5b6458a388475049611554290ef28 (patch)
tree2773e2d921c69ef334ad7119ff2ab5369e27b7f3
parentd32a5f6eed976a0a4d0510db308ffe833ab92a35 (diff)
downloadguix-89b8a6d27da5b6458a388475049611554290ef28.tar.gz
guix-89b8a6d27da5b6458a388475049611554290ef28.zip
gnu: node: Replace customized nghttp2-for-node by nghttp2.
* gnu/packages/node.scm (node) [native-inputs]: Replace nghttp2-for-node by nghttp2. [inputs]: Ditto. [arguments]<#:phases>: Adjust accordingly by skipping failing tests. Change-Id: Ia3d63ea1c428c1353d6ec6fda394ccb016eb6603
-rw-r--r--gnu/packages/node.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 7c320a00d6..6414b94278 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -48,6 +48,7 @@
#:use-module (gnu packages icu4c)
#:use-module (gnu packages libevent)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages networking)
#:use-module (gnu packages node-xyz)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -155,6 +156,11 @@
;; See also <https://github.com/nodejs/node/issues/25903>.
"test/sequential/test-performance.js"))
+ ;; These tests fail on recent versions of nghttp2
+ (for-each delete-file
+ '("test/parallel/test-http2-methods.js"
+ "test/parallel/test-http2-multiplex.js"))
+
;; This requires a DNS resolver.
(delete-file "test/parallel/test-dns.js")
@@ -297,7 +303,7 @@
http-parser
icu4c
libuv-for-node
- `(,nghttp2-for-node "lib")
+ `(,nghttp2 "lib")
openssl-1.1
zlib
;; Regular build-time dependencies.
@@ -317,7 +323,7 @@
http-parser
icu4c
libuv-for-node
- `(,nghttp2-for-node "lib")
+ `(,nghttp2 "lib")
openssl
python-wrapper ;for node-gyp (supports python3)
zlib))
e06'>system: Fix duplicate nss-certs check....* gnu/system.scm (operating-system-packages): Because packages->manifest allows other formats, don't assume it's a package object in the list. Fixes: https://issues.guix.gnu.org/70624 Change-Id: I91c64ca2c463ef5c35fa23856e4622e364e58988 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> nathan 2024-04-26system: Warn when multiple nss-certs packages are used....This can happen due to users providing 'nss-certs' and adding it to the %base-packages, which now include 'nss-certs'. * gnu/system.scm (operating-system-packages): Warn when multiple nss-certs packages are detected; keep only the latest one. Change-Id: I6104f134ea1cc155ae9e8e0ae70bb5a38fc05800 Reported-by: Ian Eure <ian@retrospec.tv> Maxim Cournoyer 2024-04-18system: Add 'nss-certs' to %base-packages-networking....See the discussion at <https://lists.gnu.org/archive/html/guix-devel/2024-04/msg00020.html>. * gnu/system.scm (%base-packages-networking): Add nss-certs. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I24f336e4bb25561d0ec9344a1a4061d2ecc9aed8 Jacob Hrbek 2024-04-17gnu: ath9k-htc-firmware: Split package....* gnu/local.mk (dist_patch_DATA): Remove ath9k-htc-firmware-objcopy.patch. * gnu/packages/firmware.scm (ath9k-htc-firmware): Remove. (ath9k-htc-ar7010-firmware, ath9k-htc-ar9271-firmware): New variables. * gnu/packages/patches/ath9k-htc-firmware-objcopy.patch: Delete file. * gnu/system.scm (%base-firmware): Use new ath9k packages. Change-Id: I86259e398427abd139c1f310a95bb15e2c03cee3 Co-authored-by: Ludovic Courtès <ludo@gnu.org> Jean-Pierre De Jesus DIAZ 2024-03-22system, home: Validate ‘services’ field value....This guides newcomers who might stick a single (service …) form in this field. * gnu/services.scm (validate-service-list): New macro. (%validate-service-list): New procedure. * gnu/system.scm (<operating-system>)[services]: Add ‘sanitize’. * gnu/home.scm (<home-environment>)[services]: Add ‘sanitize’. Change-Id: I9e29bd9a078e87b627ab766fd669ba9de79f8473 Ludovic Courtès 2024-02-19system: Omit “root=” kernel argument when root device is “none”....* gnu/system.scm (bootable-kernel-arguments): Fallback to tmpfs if root is "none". Change-Id: I35a656e71169dc786e5256d98a3c04c65043086d Signed-off-by: Ludovic Courtès <ludo@gnu.org> Nicolas Graves 2024-01-08system: hurd: Use the Shepherd 0.10.x....* gnu/system.scm (hurd-default-essential-services): Remove reference to ‘shepherd-0.8’. * gnu/system/hurd.scm (%base-packages/hurd): Replace ‘shepherd-0.8’ with ‘shepherd-0.10’. Change-Id: I9f1800693cda456286450d3d0bb6f7e3da85d55e Ludovic Courtès 2023-12-25gnu: Adjust to removing ed.scm and nano.scm...This is a follow-up to f6817e71dff7d0d9fdb55db8b85a1d3d04e2bf5a and e11e65a9ad08e18ea2faac3c9f4639a7b189bf76. * gnu/installer.scm, gnu/packages/algebra.scm, gnu/packages/base.scm, gnu/packages/cook.scm, gnu/packages/lisp.scm, gnu/packages/patchutils.scm, gnu/packages/version-control.scm, gnu/packages/web-browsers.scm, gnu/system.scm: Adjust module imports. Change-Id: I25e5519fa003c35a14b81c3dda37b24527858634 Efraim Flashner