aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-12-17 09:54:47 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:22 +0100
commit89246206f0ffb984941f804fc4155bea1dac5940 (patch)
tree42e41988298d21acb2d2fc34700e4a97646ffefc
parent202a29e787a69f3e584dbdbcfc88dbeaacb02a31 (diff)
downloadguix-89246206f0ffb984941f804fc4155bea1dac5940.tar.gz
guix-89246206f0ffb984941f804fc4155bea1dac5940.zip
gnu: python-webcolors: Update to 24.11.1.
* gnu/packages/python-web.scm (python-webcolors): Update to 24.11.1. [build-system]: Use pyproject-build-system. [arguments]: Add phase 'patch-pyproject; remove custom 'check phase. [native-inputs]: Add python-pdm-backend. Change-Id: Ifcc947d08a369dfafa6f0e0eed473bc6e372ccd6
-rw-r--r--gnu/packages/python-web.scm25
1 files changed, 14 insertions, 11 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 938bb74699..35421c8474 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -8962,24 +8962,27 @@ translate entities on HTML strings, among other things.")
(define-public python-webcolors
(package
(name "python-webcolors")
- (version "1.11.1")
+ (version "24.11.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "webcolors" version))
(sha256
- (base32 "1rkda75h2p65zx6r84c9mjavn4xpviqvqrklvdvcklapd5in1wvn"))))
- (build-system python-build-system)
+ (base32 "1xl0vn4xa03vjwx6fj19q9kgb94g65gvdf3p0ivsy0i2ydldgczc"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? inputs outputs #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest")))))))
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'patch-pyproject
+ (lambda _
+ ;; XXX Our version of python-pdm-backend does not recognize
+ ;; "dependency-groups", but is fine with the bogus
+ ;; "tool.whatever".
+ (substitute* "pyproject.toml"
+ (("\\[dependency-groups\\]") "[tool.whatever]")))))))
(native-inputs
- (list python-pytest))
+ (list python-pdm-backend python-pytest))
(home-page "https://github.com/ubernostrum/webcolors")
(synopsis "HTML/CSS color definitions library")
(description "@code{python-webcolors} is a module for working with