aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2024-10-06 19:02:30 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-10-15 08:56:49 +0200
commit88e4aaec0f2dc267b324df877b4861e734033500 (patch)
tree12d412ab845e24ff3c5026ce4b627059eaf2f948
parentd5c5b2a73bc699aaf6fa335d321db8f2ff552d54 (diff)
downloadguix-88e4aaec0f2dc267b324df877b4861e734033500.tar.gz
guix-88e4aaec0f2dc267b324df877b4861e734033500.zip
gnu: Add emacs-varuga.
* gnu/packages/emacs-xyz.scm (emacs-varuga): New variable. Change-Id: I6900893ff65011fd8aa935a6b7281e83842b2b66 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ce63ca0b86..823db069d5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16,7 +16,7 @@
;;; Copyright © 2016, 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016-2024 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016, 2017, 2018 Alex Vong <alexvong1995@gmail.com>
-;;; Copyright © 2016-2022 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2016-2022, 2024 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2017, 2018, 2019, 2020, 2022 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017, 2018, 2019, 2020, 2021, 2022 Clément Lassieur <clement@lassieur.org>
@@ -4914,6 +4914,34 @@ the ability to jump forward and backward to the next bookmark.")
Emacs buffer.")
(license license:gpl3+)))
+(define-public emacs-varuga
+ (package
+ (name "emacs-varuga")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.systemreboot.net/varuga/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "01hlnhqhys8qzfwhza1ypc436zg5lhlkx5yy71bhmrbmyfzfh0fr"))))
+ (build-system emacs-build-system)
+ (arguments (list #:tests? #t))
+ (home-page "https://git.systemreboot.net/varuga/about/")
+ (synopsis "Send iCal calendar invites by email")
+ (description
+ "Varuga allows you to format and send iCal calendar invites using your
+Emacs mail client. These invites are similar to those produced by Google
+Calendar or Outlook Calendar, and are compatible with them.
+
+Varuga populates a Message mode buffer with an iCal MIME part (using MML, the
+MIME Meta Language). It also adds a plain text part listing the time of the
+event in various configured timezones.")
+ (license license:gpl3+)))
+
(define-public emacs-caml
(package
(name "emacs-caml")