aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-03 08:06:29 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commit864b5211cdb4688f3be66975dba4e753e2e59241 (patch)
treea9794af5e3827c9a2f6308ddcf7cb9663b9d447d
parente6cfbd364a16e372b036cba73c0f94e9c24933c6 (diff)
downloadguix-864b5211cdb4688f3be66975dba4e753e2e59241.tar.gz
guix-864b5211cdb4688f3be66975dba4e753e2e59241.zip
gnu: Add python-jsonschema.
* gnu/packages/python.scm (python-jsonschema, python2-jsonschema): New variables.
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5562ed1a28..3ef862dd63 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1074,3 +1074,28 @@ is used by the Requests library to verify HTTPS requests.")
"Requests is a Python HTTP client library. It aims to be easier to use
than Python’s urllib2 library.")
(license asl2.0)))
+
+(define-public python-jsonschema
+ (package
+ (name "python-jsonschema")
+ (version "2.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://pypi.python.org/packages/source/j/jsonschema/jsonschema-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1yik3031ziygvq66rj3mzfqdgxj29sg1bkfc46wsgi7lnbqs560j"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "http://github.com/Julian/jsonschema")
+ (synopsis "Implementation of JSON Schema for Python")
+ (description
+ "Jsonschema is an implementation of JSON Schema for Python.")
+ (license expat)))
+
+(define-public python2-jsonschema
+ (package-with-python2 python-jsonschema))
d>guix-install.sh: Use the "ci.guix.info.pub" file name for clarity....Ludovic Courtès 2018-12-04etc: Add "ci.guix.info.pub" public key file....Ludovic Courtès 2018-11-23build: Binary tarball now populates the "current-guix" profile....Ludovic Courtès 2018-11-06maint: Move substitute public keys to etc/substitutes....Ludovic Courtès 2018-11-06bash completion: Restore completion of available packages for 'guix build'....Ludovic Courtès 2018-10-14guix-install.sh: Recognize armhf-linux....Ludovic Courtès 2018-10-10etc: Use git-file-name if origin is git-fetch....Pierre Neidhardt 2018-07-13etc: snippets: Add guix-commit-message-use-https-home-page....Arun Isaac 2018-07-13etc: snippets: Add new build systems to package snippet....Arun Isaac 2018-07-03bash completion: Complete files names after 'guix weather -m'....Oleg Pykhalov 2018-07-03bash completion: Complete files names after 'guix build -L'....Oleg Pykhalov 2018-06-16Add guix-daemon Bash completion file....Oleg Pykhalov 2018-05-19guix-install.sh: Fix chk_require exiting without warning....Maxim Cournoyer 2018-03-29guix-install.sh: Explicitly set root's home directory....Chris Marusich 2018-03-20Correct name and Email for ng0....ng0 2018-02-21etc: guix-install.sh: Add aarch64-linux support....Efraim Flashner 2018-02-17bash completion: Complete files names after 'guix package -m'....Oleg Pykhalov 2018-02-07etc: Add SELinux policy for the daemon....Ricardo Wurmus 2018-01-30etc: Add installation script....Ricardo Wurmus 2018-01-16etc: Add completions for fish....ng0 2017-12-15etc: Add snippets....Ricardo Wurmus