aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:16:54 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:37 +0200
commit85a118b7e14621e5dcf263f7549fea6d0fc32739 (patch)
tree40277585f79b7feab641269fa47acca243fd699e
parentda9b0b0b56750f4d657e65188a5cce9052477388 (diff)
downloadguix-85a118b7e14621e5dcf263f7549fea6d0fc32739.tar.gz
guix-85a118b7e14621e5dcf263f7549fea6d0fc32739.zip
gnu: Add texlive-ltxfileinfo.
* gnu/packages/tex.scm (texlive-ltxfileinfo): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 47d75c16f4..f1f17bc067 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2764,6 +2764,27 @@ a shell script to make a steering file that is used by the package when LaTeX
is being run.")
(license license:lppl1.2+)))
+(define-public texlive-ltxfileinfo
+ (package
+ (name "texlive-ltxfileinfo")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/support/ltxfileinfo/"
+ "scripts/ltxfileinfo/")
+ (base32
+ "1nbcplq48cw768pjyg832ymqmjr9rlrcpl6jmkq8mrvvydgy8nai")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "ltxfileinfo")))
+ (home-page "https://ctan.org/pkg/ltxfileinfo")
+ (synopsis "Print version information for a LaTeX file")
+ (description
+ "@command{ltxfileinfo} displays version information for LaTeX files.
+If no path information is given, the file is searched using
+@command{kpsewhich}.")
+ (license license:gpl3+)))
+
(define-public texlive-tex-ini-files
(package
(name "texlive-tex-ini-files")