aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 00:36:36 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:21 +0200
commit855a2219484e02f6d737d8d26465742ec222b804 (patch)
tree36361618f172ef46382cc9d11c5ceb2fd4590807
parent9692afb385829df838ddd2acd700660286201adc (diff)
downloadguix-855a2219484e02f6d737d8d26465742ec222b804.tar.gz
guix-855a2219484e02f6d737d8d26465742ec222b804.zip
gnu: Add texlive-knittingpattern.
* gnu/packages/tex.scm (texlive-knittingpattern): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8dab65394b..f8246e6234 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -17696,6 +17696,27 @@ LaTeX. The fonts are available both as Metafont source and in Adobe Type
1 format.")
(license license:lppl1.3+)))
+(define-public texlive-knittingpattern
+ (package
+ (name "texlive-knittingpattern")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/knittingpattern/"
+ "tex/latex/knittingpattern/")
+ (base32
+ "0q52213yj08bhhgwr622ss3gwhx3l1yvgv0a2g3arhp3a8iq2g9a")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/knittingpattern")
+ (synopsis "Create knitting patterns")
+ (description
+ "The class provides a simple, effective method for knitters to produce
+high-quality, attractive patterns using LaTeX. It does this by providing
+commands to handle as much of the layout of the document as possible, leaving
+the author free to concentrate on the pattern.")
+ (license license:lppl1.3+)))
+
(define-public texlive-qrcode
(package
(name "texlive-qrcode")