aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:19:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:07 +0200
commit83aa9e481816ce348035073d4056f0da199196c4 (patch)
tree990127141a24cbf2f96d8763e6a3b326d9742da1
parent5e2d90b9ec9f0f4108c617a9cbae2fae20951ca7 (diff)
downloadguix-83aa9e481816ce348035073d4056f0da199196c4.tar.gz
guix-83aa9e481816ce348035073d4056f0da199196c4.zip
gnu: Add texlive-forum.
* gnu/packages/tex.scm (texlive-forum): New variable.
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 51de0c4f62..33b084c792 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12423,6 +12423,35 @@ and templates for an introductory LaTeX course (in French) prepared for
Universite Laval, Quebec, Canada.")
(license license:cc-by4.0)))
+(define-public texlive-forum
+ (package
+ (name "texlive-forum")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/forum/"
+ "fonts/enc/dvips/forum/"
+ "fonts/map/dvips/forum/"
+ "fonts/opentype/public/forum/"
+ "fonts/tfm/public/forum/"
+ "fonts/type1/public/forum/"
+ "fonts/vf/public/forum/"
+ "tex/latex/forum/")
+ (base32
+ "07sbzd2da3i5adlbgrrxd7igyailzjwxvr3pcwmb9wl9jry1gg9m")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/forum")
+ (synopsis "Forum fonts with LaTeX support")
+ (description
+ "This package provides LaTeX, pdfLaTeX, XeLaTeX and LuaLaTeX support for
+the Forum font, designed by Denis Masharov. Forum has antique, classic Roman
+proportions. It can be used to set body texts and works well in titles and
+headlines too. It is truly multilingual, with glyphs for Central and Eastern
+Europe, Baltics, Cyrillic and Asian Cyrillic communities. There is currently
+just a regular weight and an artificially emboldened bold.")
+ (license (list license:silofl1.1 license:lppl))))
+
(define-public texlive-fouridx
(package
(name "texlive-fouridx")