aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-04-13 14:04:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-14 11:50:34 +0200
commit839241501ad571e669471a711efb9172db40f708 (patch)
tree8914135b6aed74d4feb3e8e963349df1651f5266
parent7d990e775e76c0a898c7d4b53691d1932fc0e6eb (diff)
downloadguix-839241501ad571e669471a711efb9172db40f708.tar.gz
guix-839241501ad571e669471a711efb9172db40f708.zip
gnu: Add r-ace.
* gnu/packages/bioconductor.scm (r-ace): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/bioconductor.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1401053570..bae472c8ac 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -11608,6 +11608,35 @@ enrichment, comparison, P-value calculation, shuffling, trimming, higher-order
motifs, and others.")
(license license:gpl3)))
+(define-public r-ace
+ (package
+ (name "r-ace")
+ (version "1.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ACE" version))
+ (sha256
+ (base32
+ "1nkbxldn5ba4fzfh4skwjc37gm6apwp09vzwnj2jw3b7ivmr0yr6"))))
+ (properties `((upstream-name . "ACE")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biobase r-genomicranges r-ggplot2 r-qdnaseq))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/tgac-vumc/ACE")
+ (synopsis
+ "Absolute copy number estimation from low-coverage whole genome sequencing")
+ (description
+ "This package uses segmented copy number data to estimate tumor cell
+percentage and produce copy number plots displaying absolute copy numbers. For
+this it uses segmented data from the @code{QDNAseq} package, which in turn uses
+a number of dependencies to turn mapped reads into segmented data. @code{ACE}
+will run @code{QDNAseq} or use its output rds-file of segmented data. It will
+subsequently run through all samples in the object(s), for which it will create
+individual subdirectories. For each sample, it will calculate how well the
+segments fit (the relative error) to integer copy numbers for each percentage
+of @dfn{tumor cells} (cells with divergent segments).")
+ (license license:gpl2)))
+
;; This is a CRAN package, but it depends on Bioconductor packages, so we put
;; it here.
(define-public r-activedriverwgs
f340f861938721c9'>Merge branch 'master' into core-updates-frozenLudovic Courtès 2021-11-14gnu: pinentry-tty: Update to 1.2.0....Efraim Flashner 2021-11-11gnu: gnupg: Update to 2.2.30....Tobias Geerinckx-Rice 2021-11-11gnu: gnupg: Don't explicitly return #t from phases....Tobias Geerinckx-Rice 2021-11-08gnu: packages: Remove last year's deprecations....Tobias Geerinckx-Rice 2021-10-12Merge remote-tracking branch 'origin/master' into core-updates-frozen.Mathieu Othacehe 2021-10-03gnu: python-gnupg: Honor #:tests? flag....Efraim Flashner 2021-10-03gnu: python-gnupg: Build with gnupg....Efraim Flashner 2021-10-03gnu: python-gnupg: Update to 0.4.7....Zac Berkowitz 2021-09-07Merge branch 'master' into core-updates-frozenLudovic Courtès 2021-07-27gnu: GnuPG: Update to 2.2.29....Leo Famulari 2021-08-08gnu: gnupg-1: Fix build with gcc-10....Efraim Flashner 2021-07-27gnu: GnuPG: Update to 2.2.29....Leo Famulari 2021-08-15Update copyright/name notices for Christine Lemmer-Webber....Christopher Lemmer Webber 2021-07-24gnu: Use 'search-input-file' when looking for executables....Ludovic Courtès 2021-07-23gnu: libksba: Update to 1.6.0....Marius Bakke 2021-07-23gnu: libgcrypt: Update to 1.8.8....Marius Bakke 2021-07-18Merge branch 'master' into core-updatesLudovic Courtès 2021-07-14libgpg-error: Fix cross-compilation error....Maxime Devos 2021-07-14libgpg-error: Prevent silent miscompilation some systems....Maxime Devos 2021-07-14libgpg-error: Remove trailing #f from phases....Maxime Devos 2021-07-08gnu: pinentry-bemenu: Fix license....Nicolas Goaziou 2021-07-08gnu: Add pinentry-bemenu....Nikita Domnitskii