aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 12:19:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 13:08:59 +0200
commit81d1db24d2eeaad09584c2212703453e5bbe3bd6 (patch)
tree0474c6439998a7242d090b7093a6e440a2bf0153
parent3ad3fac7a28ea8f3bf76a493dd5352f45ec0327b (diff)
downloadguix-81d1db24d2eeaad09584c2212703453e5bbe3bd6.tar.gz
guix-81d1db24d2eeaad09584c2212703453e5bbe3bd6.zip
gnu: Add texlive-platex.
* gnu/packages/tex.scm (texlive-platex): New variable.
-rw-r--r--gnu/packages/tex.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 314410f2ba..d96de4078a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13305,6 +13305,48 @@ functionality, and handling of arbitrary (multiple) private letters (analagous
LaTeX packages use of @samp{@@@@}) in nested package files.")
(license license:lppl1.3+)))
+(define-public texlive-platex
+ (package
+ (name "texlive-platex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/platex.1"
+ "doc/man/man1/platex.man1.pdf"
+ "doc/platex/base/"
+ "source/platex/base/"
+ "tex/platex/base/"
+ "tex/platex/config/")
+ (base32
+ "0a843xnp3iikjxw1klxb3j2bssm6ylhcw32s046xxm2bs527hxi8")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:create-formats #~(list "platex" "platex-dev")))
+ (propagated-inputs
+ (list texlive-atbegshi
+ texlive-atveryend
+ texlive-babel
+ texlive-cm
+ texlive-everyshi
+ texlive-firstaid
+ texlive-hyphen-base
+ texlive-l3backend
+ texlive-l3kernel
+ texlive-l3packages
+ texlive-latex
+ texlive-latex-fonts
+ texlive-ptex
+ texlive-ptex-fonts
+ texlive-tex-ini-files
+ texlive-unicode-data
+ texlive-uptex))
+ (home-page "https://ctan.org/pkg/platex")
+ (synopsis "pLaTeX2e and miscellaneous macros for pTeX")
+ (description
+ "The bundle provides pLaTeX2e and miscellaneous macros for pTeX and
+e-pTeX.")
+ (license license:bsd-3)))
+
(define-public texlive-platex-tools
(package
(name "texlive-platex-tools")