aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKing, Spencer <spencer.king@wustl.edu>2024-05-15 21:24:51 +0000
committerRicardo Wurmus <rekado@elephly.net>2024-08-26 11:39:39 +0200
commit8059adada539c86c2ce8f1353de27b0b5741fd85 (patch)
tree55a4141ded86bd5f04ff86ecffe7aa8364a28040
parenta7db59b3fd217374d1da821a51f53c987e9c96a3 (diff)
downloadguix-8059adada539c86c2ce8f1353de27b0b5741fd85.tar.gz
guix-8059adada539c86c2ce8f1353de27b0b5741fd85.zip
gnu: Add r-shinydisconnect.
* gnu/packages/cran.scm (r-shinydisconnect): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net> Change-Id: Ibf90c8902b6e6e6c45b7bdb921f310f14ac6b803
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1fe70968d3..39bd480e90 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5794,6 +5794,31 @@ extensive prebuilt widgets make it possible to build beautiful,
responsive, and powerful applications with minimal effort.")
(license license:artistic2.0)))
+(define-public r-shinydisconnect
+ (package
+ (name "r-shinydisconnect")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "shinydisconnect" version))
+ (sha256
+ (base32 "1yhppfx8jpvz48iwxnimcwqhj02vqjrfmh4z5rdn9d35p51c8zjc"))))
+ (properties `((upstream-name . "shinydisconnect")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-checkmate r-glue r-htmltools r-shiny))
+ (home-page "https://github.com/daattali/shinydisconnect")
+ (synopsis "Show a nice message when a Shiny app disconnects or errors")
+ (description
+ "This package provides a Shiny app that can disconnect for a variety of
+reasons: an unrecoverable error occurred in the app, the server went down, the
+user lost internet connection, or any other reason that might cause the Shiny
+app to lose connection to its server. With shinydisconnect, you can call
+@code{disonnectMessage} anywhere in a Shiny app's UI to add a nice message
+when this happens. It works locally (running Shiny apps within RStudio) and
+on Shiny servers.")
+ (license license:expat)))
+
(define-public r-shinyhelper
(package
(name "r-shinyhelper")