aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@friendly-machines.com>2025-02-16 14:47:28 +0100
committerDanny Milosavljevic <dannym@friendly-machines.com>2025-02-16 14:47:28 +0100
commit7f439fb38090559bdfb4b75b8abefc4fe53e9091 (patch)
tree449730daf8a79817997ff887fc771f97a0768834
parentbfb1982842d8b8ba288c933e8a104d4abdd93559 (diff)
downloadguix-7f439fb38090559bdfb4b75b8abefc4fe53e9091.tar.gz
guix-7f439fb38090559bdfb4b75b8abefc4fe53e9091.zip
gnu: sioyek: Support wayland.
* gnu/packages/pdf.scm (sioyek)[build-system]: Switch to qt-build-system. [inputs]: Add qtwayland-5. [arguments]<#:test-target>: Set to "check". Change-Id: I18f29acf1a9d85f96ace20fe6e69c87993630d67
-rw-r--r--gnu/packages/pdf.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index cf8821107b..ca28a0af14 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -1749,11 +1749,12 @@ Keywords: html2pdf, htmltopdf")
;; XXX: Fix build with mupdf-0.23.0+.
;; See also: https://github.com/ahrm/sioyek/issues/804
(patches (search-patches "sioyek-fix-build.patch"))))
- (build-system gnu-build-system)
+ (build-system qt-build-system)
(arguments
(list
#:configure-flags
#~(list (string-append "PREFIX=" #$output))
+ #:test-target "check"
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-paths
@@ -1781,6 +1782,7 @@ Keywords: html2pdf, htmltopdf")
openjpeg
qt3d-5
qtbase-5
+ qtwayland-5
zlib))
(home-page "https://sioyek.info/")
(synopsis "PDF viewer with a focus on technical books and research papers")