aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:32:11 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:48:36 +0200
commit7ef2820076048e8d94d153aa387de29b78a3bdc9 (patch)
treea5fb3adb062c2364395dd0eed4cbebc32c3001bd
parent59f51a5e42576c9c22bae6c71dd37153f929e45d (diff)
downloadguix-7ef2820076048e8d94d153aa387de29b78a3bdc9.tar.gz
guix-7ef2820076048e8d94d153aa387de29b78a3bdc9.zip
gnu: Add texlive-guitar.
* gnu/packages/tex.scm (texlive-guitar): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2c36dbab40..3fe85f2f3e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6783,6 +6783,27 @@ Currently two steps of symmetry reduction are supported.")
processed files, as well as solutions to the exercices.")
(license license:lppl1.3c+)))
+(define-public texlive-guitar
+ (package
+ (name "texlive-guitar")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/guitar/" "source/latex/guitar/"
+ "tex/latex/guitar/")
+ (base32
+ "0rywmlz59mjm59n4607qk9fa62w1c9qv9iyyja8k9vb4pc9yijrc")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/guitar")
+ (synopsis "Guitar chords and song texts")
+ (description
+ "This package provides (La)TeX macros for typesetting guitar chords over
+song texts. Note that this package only places arbitrary TeX code over the
+lyrics. To typeset the chords graphically (and not only by name), the author
+recommends use of an additional package such as @code{gchords}.")
+ (license license:lppl1.3+)))
+
(define-public texlive-gustlib
(package
(name "texlive-gustlib")