aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-05 21:27:39 -0400
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:06 +0200
commit7ee764bbe508ad0becb3e8e4e2435144de64c359 (patch)
tree8807073c0818830b82e6634be80b5127f113002f
parent18631c4d5c3af75ba1025fd11aae20a520af14bf (diff)
downloadguix-7ee764bbe508ad0becb3e8e4e2435144de64c359.tar.gz
guix-7ee764bbe508ad0becb3e8e4e2435144de64c359.zip
gnu: %objc++-search-paths: Express using $LIBRARY_PATH.
* gnu/packages/gcc.scm (%objc++-search-paths): Express using $LIBRARY_PATH.
-rw-r--r--gnu/packages/gcc.scm4
1 files changed, 1 insertions, 3 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 95c09e0924..b7173d63ba 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1373,9 +1373,7 @@ provides the GNU compiler for the Go programming language."))
(list (search-path-specification
(variable "OBJCPLUS_INCLUDE_PATH")
(files '("include")))
- (search-path-specification
- (variable "LIBRARY_PATH")
- (files '("lib" "lib64")))))
+ $LIBRARY_PATH))
(define-public gcc-objc++-4.8
(custom-gcc gcc-4.8 "gcc-objc++" '("obj-c++")