aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 09:42:03 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:40 +0200
commit7e96dbef371d33971dd31431ad0a5d494c6cb0fb (patch)
treee407ca9e61fd98e8da39d52bc17f4bebb4737fe3
parent520041c95454994f6f7d5e55c200c775eed25d0d (diff)
downloadguix-7e96dbef371d33971dd31431ad0a5d494c6cb0fb.tar.gz
guix-7e96dbef371d33971dd31431ad0a5d494c6cb0fb.zip
gnu: Add texlive-randomwalk.
* gnu/packages/tex.scm (texlive-randomwalk): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 220c4ea04d..4bf5bbccbe 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3655,6 +3655,27 @@ marginal plots (using the packages PSTricks and @code{pst-plot}), and
coordinate system).")
(license license:lppl)))
+(define-public texlive-randomwalk
+ (package
+ (name "texlive-randomwalk")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/randomwalk/"
+ "source/latex/randomwalk/"
+ "tex/latex/randomwalk/")
+ (base32
+ "1mmisgiy0c6qww6xyp9r825snh1dkmn81qjg39c7n1jxig3a8rj3")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/randomwalk")
+ (synopsis "Random walks using TikZ")
+ (description
+ "The @code{randomwalk} package provides a user command, @code{\\RandomWalk},
+to draw random walks with a given number of steps. Lengths and angles of the
+steps can be customized in various ways.")
+ (license license:lppl1.3c)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")