aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrice Waegeneire <brice@waegenei.re>2021-06-05 13:02:24 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-07-08 19:21:11 +0200
commit7bb9c3ebbb91b94fb8b1bcdf9f37e9c481a71d4d (patch)
treed04bd35e4e940ab6ded74a7a0c57acaf8244a1e7
parent25041719da372b63c7ddbb503a3d4d9effa49557 (diff)
downloadguix-7bb9c3ebbb91b94fb8b1bcdf9f37e9c481a71d4d.tar.gz
guix-7bb9c3ebbb91b94fb8b1bcdf9f37e9c481a71d4d.zip
gnu: kmod: Add zstd support.
* gnu/packages/linux.scm (kmod)[inputs]: Add zstd:lib. [arguments]: Enable zstd support. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/linux.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d2f6fab9fb..83921a786a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3383,9 +3383,10 @@ to use Linux' inotify mechanism, which allows file accesses to be monitored.")
("zstd" ,zstd)))
(inputs
`(("xz" ,xz)
- ("zlib" ,zlib)))
+ ("zlib" ,zlib)
+ ("zstd-lib" ,zstd "lib")))
(arguments
- `(#:configure-flags '("--with-xz" "--with-zlib"
+ `(#:configure-flags '("--with-xz" "--with-zlib" "--with-zstd"
"--disable-test-modules")
#:phases
(modify-phases %standard-phases