aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-14 23:17:02 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit7ae4c1022746907da090cd376507106a8133cc0d (patch)
tree09957452a4208cc2e8e78a0f46cc0040812d26cf
parentca80b8ba158e714092827a28a201e4c4f4e50983 (diff)
downloadguix-7ae4c1022746907da090cd376507106a8133cc0d.tar.gz
guix-7ae4c1022746907da090cd376507106a8133cc0d.zip
gnu: Add ghc-old-time.
* gnu/packages/haskell.scm (ghc-old-time): New variable.
-rw-r--r--gnu/packages/haskell.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index a12f245e5d..b34adddf0a 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -383,6 +383,36 @@ package.")
date and time formats.")
(license bsd-3)))
+(define-public ghc-old-time
+ (package
+ (name "ghc-old-time")
+ (version "1.1.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/old-time/old-time-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1h9b26s3kfh2k0ih4383w90ibji6n0iwamxp6rfp2lbq1y5ibjqw"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-/bin/sh
+ (lambda _
+ (setenv "CONFIG_SHELL" "sh"))))))
+ (propagated-inputs
+ `(("ghc-old-locale" ,ghc-old-locale)))
+ (home-page "http://hackage.haskell.org/package/old-time")
+ (synopsis "Time compatibility library for Haskell")
+ (description "Old-time is a package for backwards compatibility with the
+old @code{time} library. For new projects, the newer
+@uref{http://hackage.haskell.org/package/time, time library} is recommended.")
+ (license bsd-3)))
+
(define-public ghc-data-default-instances-old-locale
(package
(name "ghc-data-default-instances-old-locale")
it/gnu/services/desktop.scm?id=84261a233ecb58d7a622329d95a8d0d3fc92f886'>services: inputattach: Add 'baud-rate' parameter....Tim Gesthuizen 2019-10-20services: xfce: Add xfce4-power-manager to polkit settings....David Wilson 2019-08-28gnu: enlightenment: Update to 0.23.0....Efraim Flashner 2019-06-15services: Include USB_ModeSwitch in %desktop-services....Florian Pelz 2019-05-15services: Include ModemManager in %desktop-services....Florian Pelz 2019-05-14services: Add 'network-manager-applet' to %DESKTOP-SERVICES....Ludovic Courtès 2019-04-30services: colord: Make public and searchable....Ludovic Courtès 2019-04-30services: bluetooth: Make public and searchable....Ludovic Courtès 2019-04-26services: cups-pk-helper: Export....Ludovic Courtès 2019-04-05services: dbus: 'wrapped-dbus-service' accepts a list of variables....Ludovic Courtès 2019-04-05services: dbus: Add 'wrapped-dbus-service'....Ludovic Courtès 2019-03-28services: desktop: Switch to GDM....Ludovic Courtès 2019-03-27services: Deprecate 'xfce-desktop-service'....Ludovic Courtès 2019-03-27services: Deprecate 'gnome-desktop-service'....Ludovic Courtès 2019-03-18Correct name and email address for ng0....ng0 2019-03-18gnu: Add inputattach service....Tim Gesthuizen 2019-03-11services: mate-desktop: Deprecate the 'mate-desktop-service' procedure....Ludovic Courtès 2019-03-11services: mate-desktop: Add default value....