aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-08-31 18:27:21 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 19:06:37 +0200
commit7a1b715d55912e8f84ba8e0325ef63bb120af7da (patch)
treed00c717893748f026652cdaa1d14ad02890e4347
parent19e0b937857563e77841a4fc5433589fa98c810d (diff)
downloadguix-7a1b715d55912e8f84ba8e0325ef63bb120af7da.tar.gz
guix-7a1b715d55912e8f84ba8e0325ef63bb120af7da.zip
gnu: perf: Properly detect libtraceevent.
* gnu/packages/linux.scm (perf)[arguments]: In ‘configure’ phase, modify ‘Makefile.config’ to leave ‘PKG_CONFIG_PATH’ unchanged. Change-Id: I7b6017200ed9b28c367182b252ef694f6b2ce73b
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 88b13a0d18..3ef6479377 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5239,6 +5239,13 @@ in a digital read-out.")
(setenv "SHELL_PATH" (which "bash"))
(chdir "tools/perf")
+ ;; In Linux 6.10.6, 'Makefile.config' overrides PKG_CONFIG_PATH
+ ;; when looking for libtraceevent and thus fails to find it.
+ ;; Remove that.
+ (substitute* "Makefile.config"
+ (("PKG_CONFIG_PATH=[[:graph:]]+")
+ ""))
+
;; This file hard-codes file system layouts for specific distros
;; but not for ours; address that. With this change, one can run
;; "perf report --symfs=$HOME/.guix-profile" (without