aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 20:41:53 +0200
committerDavid Craven <david@craven.ch>2016-08-13 14:07:46 +0200
commit7a150b4d745900abde2ca31a86ededf37496dd27 (patch)
tree9051748d36f371df84b85d5a5689dee8dc6c1a6c
parent3dbb816a5f8e8d5ddbb04f409adaf4adef4d0d9b (diff)
downloadguix-7a150b4d745900abde2ca31a86ededf37496dd27.tar.gz
guix-7a150b4d745900abde2ca31a86ededf37496dd27.zip
gnu: kde-frameworks: Add kguiaddons.
* gnu/packages/kde-frameworks.scm (kguiaddons): New variable. Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
-rw-r--r--gnu/packages/kde-frameworks.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 217ce8945e..1ccb8ea192 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -450,6 +450,41 @@ such as printers, to be discovered without any user intervention or centralized
infrastructure.")
(license license:lgpl2.1+)))
+(define-public kguiaddons
+ (package
+ (name "kguiaddons")
+ (version "5.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0ig96ah20ybg5rwpswj9va2klvkh2q4amwxmgy3z4niwfsm2g3ic"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("xorg-server" ,xorg-server)))
+ (inputs
+ `(("qtbase" ,qtbase)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'start-xorg-server
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; The test suite requires a running X server.
+ (system (string-append (assoc-ref inputs "xorg-server")
+ "/bin/Xvfb :1 &"))
+ (setenv "DISPLAY" ":1")
+ #t)))))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Utilities for graphical user interfaces")
+ (description "The KDE GUI addons provide utilities for graphical user
+interfaces in the areas of colors, fonts, text, images, keyboard input.")
+ (license (list license:gpl2+ license:lgpl2.1+))))
+
(define-public kwindowsystem
(package
(name "kwindowsystem")
/td>Efraim Flashner 2016-07-15gnu: lsh: Move to (gnu packages ssh)...David Craven 2016-07-09gnu: dropbear: Update to 2016.73....Leo Famulari 2016-04-17gnu: openssh: Fix CVE-2015-8325....Leo Famulari 2016-04-14gnu: packages: Use 'search-patches' everywhere....Alex Kost 2016-03-10gnu: dropbear: Update to 2016.72 [fixes CVE-2016-3116]....Leo Famulari 2016-03-10gnu: openssh: Update to 7.2p2 [fixes CVE-2016-3115]....Leo Famulari 2016-03-01gnu: openssh: Update to 7.2p1....Leo Famulari 2016-02-29gnu: curl: Use updated libssh2 [fixes CVE-2016-7087]....Mark H Weaver 2016-02-27gnu: Fix misplaced commas (unquote)....Mark H Weaver 2016-02-24gnu: libssh: Update to 0.7.3 [fixes CVE-2016-0739]....Leo Famulari 2016-02-24gnu: libssh2: Update to 1.7.0 [fixes CVE-2016-0787]....Leo Famulari 2016-02-24gnu: dropbear: Update to 2015.71....Efraim Flashner 2016-01-15gnu: openssh: Update to 7.1p2....Mark H Weaver 2016-01-15Revert "gnu: openssh: Update to 7.1p2 [fixes CVE-0216-0778]."...Mark H Weaver 2016-01-14gnu: openssh: Update to 7.1p2 [fixes CVE-0216-0778]....Mark H Weaver 2016-01-01gnu: guile-ssh: Update to 0.9.0....Ludovic Courtès 2015-12-03gnu: openssh: Update to 7.1p1....Efraim Flashner 2015-11-30gnu: openssh: Install ssh-copy-id....Ricardo Wurmus 2015-11-30gnu: openssh: Use modify-phases syntax....Ricardo Wurmus 2015-11-23gnu: Fix a few 'source-file-name' lint warnings....Ludovic Courtès 2015-11-13gnu: Adjust formatting as recommended by 'guix lint'....宋文武